Blob Blame History Raw
From 90c65d40a00ad5a0ae70bef95bea188a948e4236 Mon Sep 17 00:00:00 2001
From: Major Hayden <major@redhat.com>
Date: Mon, 28 Mar 2022 06:59:11 -0500
Subject: [PATCH] Remove pathlib2 requirement

Fabric tries to use the standard pathlib library provided with Python 3
if it exists. The old pathlib2 requirement for Python 2.x is no longer
needed.

Signed-off-by: Major Hayden <major@mhtx.net>
---
 setup.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index e41fe6e1..0a941cc1 100644
--- a/setup.py
+++ b/setup.py
@@ -75,7 +75,7 @@ setuptools.setup(
         "CI": "https://app.circleci.com/pipelines/github/fabric/fabric",
         "Twitter": "https://twitter.com/pyfabric",
     },
-    install_requires=["invoke>=1.3,<2.0", "paramiko>=2.4", "pathlib2"],
+    install_requires=["invoke>=1.3,<2.0", "paramiko>=2.4"],
     extras_require={
         "testing": testing_deps,
         "pytest": testing_deps + pytest_deps,
-- 
2.35.1