#1 Set minimum pytest version to 3.4 for compatibility with el8
Merged a month ago by radez. Opened a month ago by ktdreyer.
rpms/ ktdreyer/python-jaraco-classes minimum-pytest  into  master

file modified
+5 -2

@@ -6,7 +6,7 @@ 

  

  Name:           python-%{pkg_name}

  Version:        2.0

- Release:        6%{?dist}

+ Release:        7%{?dist}

  Summary:        Utility functions for Python class constructs

  

  License:        MIT

@@ -24,7 +24,7 @@ 

  

  BuildConflicts: python3dist(pytest) = 3.7.3

  BuildRequires:  python3-devel

- BuildRequires:  python3dist(pytest) >= 3.5

+ BuildRequires:  python3dist(pytest) >= 3.4

  BuildRequires:  python3dist(pytest-flake8)

  BuildRequires:  python3dist(setuptools)

  BuildRequires:  python3dist(setuptools-scm) >= 1.15

@@ -87,6 +87,9 @@ 

  %endif

  

  %changelog

+ * Mon Nov 11 2019 Ken Dreyer <kdreyer@redhat.com> - 2.0-7

+ - Set minimum pytest version to 3.4 for compatibility with el8

+ 

  * Thu Oct 03 2019 Miro HronĨok <mhroncok@redhat.com> - 2.0-6

  - Rebuilt for Python 3.8.0rc1 (#1748018)

  

While we work to bring CherryPy to EPEL 8, we found that this pytest requirement for version 3.5+ is too high, because RHEL 8 ships with pytest 3.4.2.

There is no explanation in the upstream Git commit log that bumps to 3.5. My guess is that it was the most recent version of pytest at the time or something.

This package builds fine with python3-pytest-3.4.2-11.el8, so I'm submitting this change here. I'd like to keep a (future) epel8 branch in sync with Rawhide as long as that is reasonable.

There is a bigger problem here: flake8 is not yet in EPEL 8 (rhbz#1757463), and in fact the jaraco-classes project does not have any of its own unit tests - it is only running pytest-flake8.

I'm closing this in favor of #2

Pull-Request has been merged by radez

a month ago

Ah shoot, I didn't get that last comment before I merged it. Sry about that.

No problem :) I don't see any particular harm in this change.

Metadata