#1 Update Python 2 dependency declarations to new packaging standards
Merged 4 years ago by mrunge. Opened 4 years ago by ishcherb.
rpms/ ishcherb/python-kombu pyambiguous  into  master

file modified
+22 -18
@@ -6,7 +6,7 @@ 

  

  Name:           python-%{srcname}

  Version:        4.0.2

- Release:        6%{?dist}

+ Release:        7%{?dist}

  Epoch:          1

  Summary:        An AMQP Messaging Framework for Python

  
@@ -21,23 +21,23 @@ 

  BuildArch: noarch

  

  BuildRequires:  python2-devel

- BuildRequires:  python-setuptools

- BuildRequires:  python-nose

- BuildRequires:  python-anyjson

- 

- BuildRequires:  python-nose-cover3

- BuildRequires:  python-coverage

- BuildRequires:  python-mock

- BuildRequires:  python-simplejson

- BuildRequires:  PyYAML

- BuildRequires:  python-msgpack

- BuildRequires:  python-amqp

- BuildRequires:  python-pymongo

+ BuildRequires:  python2-setuptools

+ BuildRequires:  python2-nose

+ BuildRequires:  python2-anyjson

+ 

+ BuildRequires:  python2-nose-cover3

+ BuildRequires:  python2-coverage

+ BuildRequires:  python2-mock

+ BuildRequires:  python2-simplejson

+ BuildRequires:  python2-pyyaml

+ BuildRequires:  python2-msgpack

+ BuildRequires:  python2-amqp

+ BuildRequires:  python2-pymongo

  

  # For documentation

- #BuildRequires:  pymongo python-sphinx

+ #BuildRequires:  python2-pymongo python2-sphinx

  #This causes tests error, needs fixing upstream. Incompatible with python > 2.7

- #BuildRequires:  python-couchdb

+ #BuildRequires:  python2-couchdb

  

  %description

  AMQP is the Advanced Message Queuing Protocol, an open standard protocol
@@ -51,8 +51,8 @@ 

  

  %package -n python2-%{srcname}

  Summary:        %{sum}

- Requires:       python-amqp >= 2.1.4

- Requires:       python-anyjson >= 0.3.3

+ Requires:       python2-amqp >= 2.1.4

+ Requires:       python2-anyjson >= 0.3.3

  Requires:       python2-vine

  

  # test requirements
@@ -60,7 +60,7 @@ 

  BuildRequires:  python2-pytest-cov

  BuildRequires:  python2-vine

  BuildRequires:  python2-case

- BuildRequires:  pytz

+ BuildRequires:  python2-pytz

  %{?python_provide:%python_provide python2-%{srcname}}

  

  %description -n python2-%{srcname}
@@ -140,6 +140,10 @@ 

  %endif

  

  %changelog

+ * Thu Jan 25 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1:4.0.2-7

+ - Update Python 2 dependency declarations to new packaging standards

+   (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)

+ 

  * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:4.0.2-6

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

  

This package uses names with ambiguous python- prefix in requirements.

According to Fedora Packaging guidelines for Python, packages must use names with either python2- or python3- prefix in requirements where available.
We are aiming to rename python-* dependencies to python2-*, so we can later switch the python-* namespace to Python 3.

This PR is part of Fedora's Switch to Python 3 effort.

Note that, although this PR was created automatically, we will respond to any comments or issues which you might find with it. We will keep the PR open for review for a week, and if there's no feedback we'll merge it. There is no need to build the package right after merge, this change can wait for the next package rebuild.
The local mock build passed, for Koji scratch build please see simple-koji-ci result.

Note: please do not backport this to f26, f27 branch(es) as some of the modified requirements are not available there

This PR was opened automatically, for source code see here

Pull-Request has been merged by mrunge

4 years ago
Metadata