#4 Update to 4.6.6
Merged 2 years ago by mrunge. Opened 2 years ago by ykarel.
rpms/ ykarel/python-kombu master  into  master

file modified
+1
@@ -47,3 +47,4 @@ 

  /kombu-4.6.1.tar.gz

  /kombu-4.6.3.tar.gz

  /kombu-4.6.4.tar.gz

+ /kombu-4.6.6.tar.gz

file removed
-49
@@ -1,49 +0,0 @@ 

- From 79133433e30e5a495e3e3aa6c255182054f456fe Mon Sep 17 00:00:00 2001

- From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>

- Date: Tue, 20 Aug 2019 11:30:02 +0200

- Subject: [PATCH] Use importlib.metadata from the standard library on Python

-  3.8+

- 

- ---

-  kombu/utils/compat.py    | 6 +++++-

-  requirements/default.txt | 2 +-

-  tox.ini                  | 1 +

-  3 files changed, 7 insertions(+), 2 deletions(-)

- 

- diff --git a/kombu/utils/compat.py b/kombu/utils/compat.py

- index c5f0bf118..a741c4350 100644

- --- a/kombu/utils/compat.py

- +++ b/kombu/utils/compat.py

- @@ -7,7 +7,11 @@

-  from functools import wraps

-  

-  from contextlib import contextmanager

- -import importlib_metadata

- +

- +try:

- +    from importlib import metadata as importlib_metadata

- +except ImportError:

- +    import importlib_metadata

-  

-  from kombu.five import reraise

-  

- diff --git a/requirements/default.txt b/requirements/default.txt

- index 00e57cc09..e3ec1c894 100644

- --- a/requirements/default.txt

- +++ b/requirements/default.txt

- @@ -1,2 +1,2 @@

-  amqp>=2.5.1,<3.0

- -importlib-metadata>=0.18

- +importlib-metadata>=0.18; python_version<"3.8"

- diff --git a/tox.ini b/tox.ini

- index 6bedd0de8..f781d0229 100644

- --- a/tox.ini

- +++ b/tox.ini

- @@ -34,6 +34,7 @@ basepython =

-      3.5: python3.5

-      3.6,apicheck,pydocstyle: python3.6

-      3.7: python3.7

- +    3.8: python3.8

-      pypy,pypy3: pypy

-  

-  install_command = python -m pip --disable-pip-version-check install {opts} {packages}

file modified
+7 -7
@@ -13,8 +13,8 @@ 

  %global srcname kombu

  

  Name:           python-%{srcname}

- Version:        4.6.4

- Release:        4%{?dist}

+ Version:        4.6.6

+ Release:        1%{?dist}

  Epoch:          1

  Summary:        An AMQP Messaging Framework for Python

  
@@ -23,9 +23,6 @@ 

  URL:            http://kombu.readthedocs.org/

  Source0:        https://github.com/celery/kombu/archive/%{version}/%{srcname}-%{version}.tar.gz

  

- # Only use importlib_metadata on Python < 3.8, use stdlib on 3.8+

- Patch0:         https://github.com/celery/kombu/pull/1086.patch

- 

  BuildArch: noarch

  

  %description
@@ -41,7 +38,7 @@ 

  %if %{with python2}

  %package -n python2-%{srcname}

  Summary:        %{summary}

- Requires:       python2-amqp >= 2.1.4

+ Requires:       python2-amqp >= 2.5.2

  Requires:       python2-vine

  

  BuildRequires:  python2-devel
@@ -88,7 +85,7 @@ 

  %if %{with python3}

  %package -n python3-%{srcname}

  Summary:        %{summary}

- Requires:       python3-amqp >= 2.1.4

+ Requires:       python3-amqp >= 2.5.2

  Requires:       python3-vine

  

  BuildRequires:  python3-devel
@@ -149,6 +146,9 @@ 

  %endif

  

  %changelog

+ * Tue Dec 03 2019 Yatin Karel <ykarel@redhat.com> - 4.6.6-1

+ - Update to 4.6.6

+ 

  * Thu Oct 03 2019 Miro HronĨok <mhroncok@redhat.com> - 1:4.6.4-4

  - Rebuilt for Python 3.8.0rc1 (#1748018)

  

file modified
+1 -1
@@ -1,1 +1,1 @@ 

- SHA512 (kombu-4.6.4.tar.gz) = fe5e4d0b54bbde23983d557b7593b77982aece76277a8c4c69543c18e89d6224ba914da1024b0cb5565915503d60dcd7110d4c6b4e707a3c642c9c26bb7691ad

+ SHA512 (kombu-4.6.6.tar.gz) = b515d5d2d52212ca2b38005fde13e95eaa289f473dead2b403199f4d62ebf7dde3a32f81468af50fff47bd725041c2a7f7df7661da987beece546852e636db28

no initial comment

Pull-Request has been merged by mrunge

2 years ago