Blob Blame History Raw
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

%define srcname markdown2

Name:           python-%{srcname}
Version:        1.0.1.17
Release:        1%{?dist}
Summary:        A fast and complete Python implementation of Markdown
Group:          Development/Languages
License:        MIT
URL:            http://code.google.com/p/python-%{srcname}/
Source0:        http://pypi.python.org/packages/source/m/%{srcname}/%{srcname}-%{version}.zip
# reported upstream as issue #39
Patch0:         python-markdown2-pygments.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch
BuildRequires:  python-devel
BuildRequires:  python-pygments

%description
Markdown is a text-to-HTML filter; it translates an easy-to-read /
easy-to-write structured text format into HTML. Markdown's text format
is most similar to that of plain text email, and supports features
such as headers, emphasis, code blocks, blockquotes, and links.

This is a fast and complete Python implementation of the Markdown
spec.

For information about markdown itself, see
http://daringfireball.net/projects/markdown/


%prep
%setup0 -q -n %{srcname}-%{version}
%patch0 -p1


%build
%{__python} setup.py build


%install
rm -rf %{buildroot}
%{__python} setup.py install -O1 --skip-build --root %{buildroot}

# remove shebangs and fix permissions
find %{buildroot}%{python_sitelib} \( -name '*.py' -o -name 'py.*' \) \
  -exec sed -i '1{/^#!/d}' {} \; \
  -exec chmod u=rw,go=r {} \;


%clean
rm -rf %{buildroot}


%check
cd test
%{__python} test.py


%files
%defattr(-,root,root,-)
%doc CHANGES.txt LICENSE.txt README.txt TODO.txt
%{python_sitelib}/*
%{_bindir}/markdown2


%changelog
* Thu Jun  3 2010 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.17-1
- Update to 1.0.17.
- Add patch for failing test.

* Tue Dec 29 2009 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.16-2
- Patch for older pygments on rhel no longer needed, pygments has been
  updated in EPEL.

* Fri Dec 18 2009 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.16-1
- Update to 1.0.1.16.

* Thu Oct  8 2009 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.15-1
- Update to 1.0.1.15. Fixes three issues, two of them being
  security-related.

* Wed Sep  2 2009 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.13-3
- Patch syntax_color test case for older pygments version on rhel.

* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Sat Jul 11 2009 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.13-1
- Update to 1.0.1.13.

* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.1.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.1.11-2
- Rebuild for Python 2.6

* Wed Oct  1 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.11-1
- Update to 1.0.11, also fixes the syntax_color test for the latest
  Pygments (should fix FTBFS bug 465049).

* Fri Sep 26 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.10-1
- Update to 1.0.1.10.

* Fri Sep 12 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.9-1
- Update to 1.0.1.9.

* Thu Sep 11 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.8-1
- Update to 1.0.1.8.
- Simplify the cmdline wrapper.

* Tue Sep  9 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.1.7-1
- New package.