From 37d4ff97c542af3885ec28e46f7ec827db33f829 Mon Sep 17 00:00:00 2001 From: Thomas Moschny Date: Jun 03 2010 11:06:27 +0000 Subject: Update to 1.0.1.17. --- diff --git a/.cvsignore b/.cvsignore index ee659b6..a708fa1 100644 --- a/.cvsignore +++ b/.cvsignore @@ -1 +1 @@ -markdown2-1.0.1.16.zip +markdown2-1.0.1.17.zip diff --git a/import.log b/import.log index 65be7c3..6f1c152 100644 --- a/import.log +++ b/import.log @@ -6,3 +6,4 @@ python-markdown2-1_0_1_13-1_fc11:HEAD:python-markdown2-1.0.1.13-1.fc11.src.rpm:1 python-markdown2-1_0_1_13-3_fc11:HEAD:python-markdown2-1.0.1.13-3.fc11.src.rpm:1251993409 python-markdown2-1_0_1_15-1_fc11:HEAD:python-markdown2-1.0.1.15-1.fc11.src.rpm:1254989197 python-markdown2-1_0_1_16-1_fc12:HEAD:python-markdown2-1.0.1.16-1.fc12.src.rpm:1262115710 +python-markdown2-1_0_1_17-1_fc13:HEAD:python-markdown2-1.0.1.17-1.fc13.src.rpm:1275563138 diff --git a/markdown2-old-pygments.patch b/markdown2-old-pygments.patch deleted file mode 100644 index f2fa02d..0000000 --- a/markdown2-old-pygments.patch +++ /dev/null @@ -1,11 +0,0 @@ -diff -up markdown2-1.0.1.13/test/tm-cases/syntax_color.html.orig markdown2-1.0.1.13/test/tm-cases/syntax_color.html ---- markdown2-1.0.1.13/test/tm-cases/syntax_color.html.orig 2009-04-07 16:39:22.000000000 +0200 -+++ markdown2-1.0.1.13/test/tm-cases/syntax_color.html 2009-09-02 22:19:38.000000000 +0200 -@@ -1,6 +1,6 @@ -

Here is some sample code:

- --
import sys
-+
import sys
- def main(argv=sys.argv):
-     logging.basicConfig()
-     log.info('hi')
diff --git a/python-markdown2-pygments.patch b/python-markdown2-pygments.patch
new file mode 100644
index 0000000..883620b
--- /dev/null
+++ b/python-markdown2-pygments.patch
@@ -0,0 +1,21 @@
+diff --git a/test/tm-cases/syntax_color_opts.html b/test/tm-cases/syntax_color_opts.html
+index 07a55fd..7a449e0 100644
+--- a/test/tm-cases/syntax_color_opts.html
++++ b/test/tm-cases/syntax_color_opts.html
+@@ -1,6 +1,6 @@
+ 

Here is some sample code:

+ +-
import sys
++
import sys
+ def main(argv=sys.argv):
+     logging.basicConfig()
+     log.info('hi')
+@@ -8,7 +8,7 @@
+ 
+ 

and:

+ +-
use 'zlib'
++
use 'zlib'
+ sub main(argv)
+     puts 'hi'
+ end
diff --git a/python-markdown2.spec b/python-markdown2.spec
index 1fff31c..07678f5 100644
--- a/python-markdown2.spec
+++ b/python-markdown2.spec
@@ -3,15 +3,15 @@
 %define srcname markdown2
 
 Name:           python-%{srcname}
-Version:        1.0.1.16
+Version:        1.0.1.17
 Release:        1%{?dist}
 Summary:        A fast and complete Python implementation of Markdown
 Group:          Development/Languages
 License:        MIT
 URL:            http://code.google.com/p/python-%{srcname}/
 Source0:        http://pypi.python.org/packages/source/m/%{srcname}/%{srcname}-%{version}.zip
-# needed on rhel with python-pygments 0.9
-Patch0:         markdown2-old-pygments.patch
+# reported upstream as issue #39
+Patch0:         python-markdown2-pygments.patch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch:      noarch
 BuildRequires:  python-devel
@@ -32,9 +32,7 @@ http://daringfireball.net/projects/markdown/
 
 %prep
 %setup0 -q -n %{srcname}-%{version}
-%if 0%{?rhel}
 %patch0 -p1
-%endif
 
 
 %build
@@ -68,6 +66,14 @@ cd test
 
 
 %changelog
+* Thu Jun  3 2010 Thomas Moschny  - 1.0.1.17-1
+- Update to 1.0.17.
+- Add patch for failing test.
+
+* Tue Dec 29 2009 Thomas Moschny  - 1.0.1.16-2
+- Patch for older pygments on rhel no longer needed, pygments has been
+  updated in EPEL.
+
 * Fri Dec 18 2009 Thomas Moschny  - 1.0.1.16-1
 - Update to 1.0.1.16.
 
diff --git a/sources b/sources
index d02352c..c970cf1 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-d04a8e3743134a2800816e88213a1728  markdown2-1.0.1.16.zip
+5f67ad41e925c4f52bec0b2cd5014002  markdown2-1.0.1.17.zip