From 52fdca7955ce9631a79b843c1d0231ec1208bf86 Mon Sep 17 00:00:00 2001 From: Thomas Moschny Date: Oct 08 2009 08:25:04 +0000 Subject: Update to 1.0.1.15. --- diff --git a/.cvsignore b/.cvsignore index f074db7..5f02667 100644 --- a/.cvsignore +++ b/.cvsignore @@ -1 +1 @@ -markdown2-1.0.1.11.tar.gz +markdown2-1.0.1.15.zip diff --git a/import.log b/import.log index 336bd94..7d18891 100644 --- a/import.log +++ b/import.log @@ -2,3 +2,4 @@ python-markdown2-1_0_1_7-1_fc9:HEAD:python-markdown2-1.0.1.7-1.fc9.src.rpm:12211 python-markdown2-1_0_1_8-1_fc9:HEAD:python-markdown2-1.0.1.8-1.fc9.src.rpm:1221168324 python-markdown2-1_0_1_9-1_fc9:HEAD:python-markdown2-1.0.1.9-1.fc9.src.rpm:1221203243 python-markdown2-1_0_1_11-1_fc9:HEAD:python-markdown2-1.0.1.11-1.fc9.src.rpm:1222984575 +python-markdown2-1_0_1_15-1_fc11:F-10:python-markdown2-1.0.1.15-1.fc11.src.rpm:1254990220 diff --git a/markdown2-old-pygments.patch b/markdown2-old-pygments.patch new file mode 100644 index 0000000..f2fa02d --- /dev/null +++ b/markdown2-old-pygments.patch @@ -0,0 +1,11 @@ +diff -up markdown2-1.0.1.13/test/tm-cases/syntax_color.html.orig markdown2-1.0.1.13/test/tm-cases/syntax_color.html +--- markdown2-1.0.1.13/test/tm-cases/syntax_color.html.orig 2009-04-07 16:39:22.000000000 +0200 ++++ markdown2-1.0.1.13/test/tm-cases/syntax_color.html 2009-09-02 22:19:38.000000000 +0200 +@@ -1,6 +1,6 @@ +

Here is some sample code:

+ +-
import sys
++
import sys
+ def main(argv=sys.argv):
+     logging.basicConfig()
+     log.info('hi')
diff --git a/python-markdown2.spec b/python-markdown2.spec
index 6fb5425..5f6438a 100644
--- a/python-markdown2.spec
+++ b/python-markdown2.spec
@@ -3,13 +3,15 @@
 %define srcname markdown2
 
 Name:           python-%{srcname}
-Version:        1.0.1.11
+Version:        1.0.1.15
 Release:        1%{?dist}
 Summary:        A fast and complete Python implementation of Markdown
 Group:          Development/Languages
 License:        MIT
 URL:            http://code.google.com/p/python-%{srcname}/
-Source0:        http://pypi.python.org/packages/source/m/%{srcname}/%{srcname}-%{version}.tar.gz
+Source0:        http://pypi.python.org/packages/source/m/%{srcname}/%{srcname}-%{version}.zip
+# needed on rhel with python-pygments 0.9
+Patch0:         markdown2-old-pygments.patch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch:      noarch
 BuildRequires:  python-devel
@@ -30,6 +32,9 @@ http://daringfireball.net/projects/markdown/
 
 %prep
 %setup0 -q -n %{srcname}-%{version}
+%if 0%{?rhel}
+%patch0 -p1
+%endif
 
 
 %build
@@ -63,6 +68,25 @@ cd test
 
 
 %changelog
+* Thu Oct  8 2009 Thomas Moschny  - 1.0.1.15-1
+- Update to 1.0.1.15. Fixes three issues, two of them being
+  security-related.
+
+* Wed Sep  2 2009 Thomas Moschny  - 1.0.1.13-3
+- Patch syntax_color test case for older pygments version on rhel.
+
+* Sun Jul 26 2009 Fedora Release Engineering  - 1.0.1.13-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Sat Jul 11 2009 Thomas Moschny  - 1.0.1.13-1
+- Update to 1.0.1.13.
+
+* Thu Feb 26 2009 Fedora Release Engineering  - 1.0.1.11-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Sat Nov 29 2008 Ignacio Vazquez-Abrams  - 1.0.1.11-2
+- Rebuild for Python 2.6
+
 * Wed Oct  1 2008 Thomas Moschny  - 1.0.1.11-1
 - Update to 1.0.11, also fixes the syntax_color test for the latest
   Pygments (should fix FTBFS bug 465049).
diff --git a/sources b/sources
index 32fe197..b6cd812 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-dbeb26dd3b03a1a2ec8b46fa243b3331  markdown2-1.0.1.11.tar.gz
+b55772f3303d9cf3cf24f7759ee3bca3  markdown2-1.0.1.15.zip