#1 Explicitly BuildRequire python3-setuptools
Merged 8 months ago by fantom. Opened 8 months ago by churchyard.
rpms/ churchyard/python-omemo require_setuptools  into  rawhide

file modified
+1
@@ -12,6 +12,7 @@ 

  BuildArch:      noarch

  BuildRequires:  python3-devel

  BuildRequires:  python3-cryptography

+ BuildRequires:  python3-setuptools

  BuildRequires:  python3-x3dh

  #BuildRequires:  python3-pytest

  # For tests

See https://fedoraproject.org/wiki/Changes/Reduce_dependencies_on_python3-setuptools

The error without setuptools is:

+ /usr/bin/python3 setup.py build '--executable=/usr/bin/python3 -s'
Traceback (most recent call last):
  File "/builddir/build/BUILD/python-omemo-0.12.0-beta/setup.py", line 1, in <module>
    from setuptools import setup, find_packages
ModuleNotFoundError: No module named 'setuptools'
error: Bad exit status from /var/tmp/rpm-tmp.TZcp5Y (%build)

Pull-Request has been merged by fantom

8 months ago
Metadata