775b644
%global pypi_name pbr
775b644
775b644
Name:           python-%{pypi_name}
f835897
Version:        0.6
b71f609
Release:        1%{?dist}
775b644
Summary:        Python Build Reasonableness
775b644
775b644
License:        ASL 2.0
775b644
URL:            http://pypi.python.org/pypi/pbr
775b644
Source0:        http://pypi.python.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
775b644
BuildArch:      noarch
318a0aa
318a0aa
Requires:       python-pip
775b644
 
775b644
BuildRequires:  python2-devel
97e9a58
# very new required, when also using tests
f835897
BuildRequires:  python-d2to1 >= 0.2.10
f835897
#BuildRequires:  python-d2to1
fdf9f19
# not necessary, but listed in requirements.txt
fdf9f19
# Requires:       python-setuptools_git
fdf9f19
# BuildRequires:  python-setuptools_git
f835897
#BuildRequires:  python-testtools
97e9a58
#BuildRequires:  python-testscenarios
f835897
# not packaged yet:
f835897
#BuildRequires:  python-discover
f835897
f835897
#BuildRequires:  python-coverage >= 3.6
f835897
#BuildRequires:  python-flake8
f835897
#BuildRequires:  python-mox
f835897
#BuildRequires:  python-testrepository
f835897
#BuildRequires:  python-subunit
f835897
#BuildRequires:  python-testresources
4aa6093
4aa6093
%if 0%{?rhel}==6
4aa6093
BuildRequires: python-sphinx10
4aa6093
%else
4aa6093
BuildRequires: python-sphinx >= 1.1.3
4aa6093
%endif
4aa6093
775b644
775b644
%description
775b644
PBR is a library that injects some useful and sensible default behaviors into 
775b644
your setuptools run. It started off life as the chunks of code that were copied
775b644
between all of the OpenStack projects. Around the time that OpenStack hit 18 
775b644
different projects each with at least 3 active branches, it seems like a good 
775b644
time to make that code into a proper re-usable library.
775b644
775b644
%prep
775b644
%setup -q -n %{pypi_name}-%{version}
cb36574
# Remove the requirements file so that pbr hooks don't add it
cb36574
# to distutils requiers_dist config
cb36574
rm -rf {test-,}requirements.txt
5d3fd27
775b644
# Remove bundled egg-info
775b644
rm -rf %{pypi_name}.egg-info
775b644
775b644
775b644
%build
775b644
%{__python} setup.py build
775b644
775b644
# generate html docs 
4aa6093
%if 0%{?rhel}==6
4aa6093
sphinx-1.0-build doc/source html
4aa6093
%else
775b644
sphinx-build doc/source html
4aa6093
%endif
775b644
# remove the sphinx-build leftovers
775b644
rm -rf html/.{doctrees,buildinfo}
775b644
775b644
775b644
%install
775b644
%{__python} setup.py install --skip-build --root %{buildroot}
775b644
775b644
%check
97e9a58
# we don't have the necessary br's, yet
97e9a58
#%{__python} setup.py test
775b644
775b644
%files
775b644
%doc html README.rst LICENSE
775b644
%{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
775b644
%{python_sitelib}/%{pypi_name}
7421937
775b644
%changelog
f835897
* Tue Feb 11 2014 Matthias Runge <mrunge@redhat.com> - 0.6.0-1
f835897
- update to 0.6.0 (rhbz#1061124)
f835897
b71f609
* Fri Nov 01 2013 Matthias Runge <mrunge@redhat.com> - 0.5.23-1
b71f609
- update to 0.5.23 (rhbz#1023926)
b71f609
318a0aa
* Tue Aug 13 2013 Matthias Runge <mrunge@redhat.com> - 0.5.21-2
318a0aa
- add requirement python-pip (rhbz#996192)
cb36574
- remove requirements.txt
318a0aa
f13711f
* Thu Aug 08 2013 Matthias Runge <mrunge@redhat.com> - 0.5.21-1
f13711f
- update to 0.5.21 (rhbz#990008)
f13711f
9a0991e
* Fri Jul 26 2013 Matthias Runge <mrunge@redhat.com> - 0.5.19-2
9a0991e
- remove one buildrequires: python-sphinx
9a0991e
6944a09
* Mon Jul 22 2013 Matthias Runge <mrunge@redhat.com> - 0.5.19-1
6944a09
- update to python-pbr-0.5.19 (rhbz#983008)
6944a09
45bd1a0
* Mon Jun 24 2013 Matthias Runge <mrunge@redhat.com> - 0.5.17-1
45bd1a0
- update to python-pbr-0.5.17 (rhbz#976026)
45bd1a0
37c09a1
* Wed Jun 12 2013 Matthias Runge <mrunge@redhat.com> - 0.5.16-1
37c09a1
- update to 0.5.16 (rhbz#973553)
37c09a1
eb026da
* Tue Jun 11 2013 Matthias Runge <mrunge@redhat.com> - 0.5.14-1
eb026da
- update to 0.5.14 (rhbz#971736)
eb026da
5d3fd27
* Fri May 31 2013 Matthias Runge <mrunge@redhat.com> - 0.5.11-2
5d3fd27
- remove requirement setuptools_git
4aa6093
- fix docs build under rhel
5d3fd27
97e9a58
* Fri May 17 2013 Matthias Runge <mrunge@redhat.com> - 0.5.11-1
97e9a58
- update to 0.5.11 (rhbz#962132)
97e9a58
- disable tests, as requirements can not be fulfilled right now
7421937
775b644
* Thu Apr 25 2013 Matthias Runge <mrunge@redhat.com> - 0.5.8-1
775b644
- Initial package.