Blob Blame Raw
diff -ur praw-3.6.0-orig/praw/__init__.py praw-3.6.0/praw/__init__.py
--- praw-3.6.0-orig/praw/__init__.py	2016-11-16 08:38:56.293851445 +0100
+++ praw-3.6.0/praw/__init__.py	2016-11-16 08:41:38.863346993 +0100
@@ -48,7 +48,6 @@
 from six.moves import html_entities, http_cookiejar
 from six.moves.urllib.parse import parse_qs, urlparse, urlunparse
 # pylint: enable=F0401
-from update_checker import update_check
 from warnings import warn_explicit
 
 
@@ -364,7 +363,6 @@
         # Check for updates if permitted and this is the first Reddit instance
         if not disable_update_check and not BaseReddit.update_checked \
                 and self.config.check_for_updates:
-            update_check(__name__, __version__)
             BaseReddit.update_checked = True
 
         # Warn against a potentially incompatible version of pyOpenSSL
diff -ur praw-3.6.0-orig/setup.py praw-3.6.0/setup.py
--- praw-3.6.0-orig/setup.py	2016-11-16 08:38:56.288851430 +0100
+++ praw-3.6.0/setup.py	2016-11-16 08:39:41.862990350 +0100
@@ -16,8 +16,7 @@
 
 dependencies = ['decorator >=4.0.9, <4.1',
                 'requests >=2.3.0',
-                'six ==1.10',
-                'update_checker >=0.12, <1.0']
+                'six ==1.10']
 
 try:
     from OpenSSL import __version__ as opensslversion