#2 Update to 2.6.1 for pytest 4 compatibility
Merged 2 years ago by orion. Opened 2 years ago by churchyard.
rpms/ churchyard/python-pytest-cov 2.6.1  into  master

file modified
+1
@@ -7,3 +7,4 @@ 

  /pytest-cov-2.5.0.tar.gz

  /pytest-cov-2.5.1.tar.gz

  /pytest-cov-2.6.0.tar.gz

+ /pytest-cov-2.6.1.tar.gz

file modified
+20 -19
@@ -1,8 +1,8 @@ 

  %global srcname pytest-cov

  

  Name:           python-%{srcname}

- Version:        2.6.0

- Release:        3%{?dist}

+ Version:        2.6.1

+ Release:        1%{?dist}

  Summary:        Pytest plugin for coverage reporting

  

  License:        MIT
@@ -20,17 +20,15 @@ 

  Summary:        Pytest plugin for coverage reporting

  BuildRequires:  python2-devel

  BuildRequires:  python2-setuptools

- BuildRequires:  python2-pytest

- BuildRequires:  python2-coverage >= 4.4

  # For tests

- #  Not packaged

- #  BuildRequires:  python2-fields

- BuildRequires:  python2-process-tests

- BuildRequires:  python2-six

- BuildRequires:  python2-virtualenv

- BuildRequires:  python2-pytest-xdist

- Requires:       python2-pytest

- Requires:       python2-coverage >= 4.4

+ #  Not packaged: python2-fields

+ #BuildRequires:  python2-pytest

+ #BuildRequires:  python2-coverage >= 4.4

+ #BuildRequires:  python2-fields

+ #BuildRequires:  python2-process-tests

+ #BuildRequires:  python2-six

+ #BuildRequires:  python2-virtualenv

+ #BuildRequires:  python2-pytest-xdist

  %{?python_provide:%python_provide python2-%{srcname}}

  

  %description -n python2-%{srcname}
@@ -45,14 +43,11 @@ 

  BuildRequires:  python%{python3_pkgversion}-pytest

  BuildRequires:  python%{python3_pkgversion}-coverage >= 4.4

  # For tests

- #  Not packaged

- #  BuildRequires:  python%{python3_pkgversion}-fields

+ BuildRequires:  python%{python3_pkgversion}-fields

  BuildRequires:  python%{python3_pkgversion}-process-tests

  BuildRequires:  python%{python3_pkgversion}-six

  BuildRequires:  python%{python3_pkgversion}-virtualenv

  BuildRequires:  python%{python3_pkgversion}-pytest-xdist

- Requires:       python%{python3_pkgversion}-pytest

- Requires:       python%{python3_pkgversion}-coverage >= 4.4

  %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}

  

  %description -n python%{python3_pkgversion}-%{srcname}
@@ -76,9 +71,12 @@ 

  

  

  %check

- # Tests fail https://github.com/pytest-dev/pytest-cov/issues/90

- PYTHONPATH=%{buildroot}%{python2_sitelib}:$PWD/tests py.test-%{python2_version} -vv || :

- PYTHONPATH=%{buildroot}%{python3_sitelib}:$PWD/tests py.test-%{python3_version} -vv || :

+ # Python 2 tests have unpackaged dependencies

+ # test_dist_missing_data needs internet

+ # test_central_subprocess/dist_subprocess https://github.com/pytest-dev/pytest-cov/issues/90

+ # test_subprocess_with_path_aliasing and test_dist_combine_racecondition tries to match strings and fails, mostly version mismatch

+ PYTHONPATH=%{buildroot}%{python3_sitelib}:$PWD/tests py.test-%{python3_version} -vv \

+     -k "not test_dist_missing_data and not test_subprocess_with_path_aliasing and not test_dist_combine_racecondition and not central_subprocess and not dist_subprocess"

  

  

  %files -n python2-%{srcname}
@@ -93,6 +91,9 @@ 

  

  

  %changelog

+ * Thu Apr 04 2019 Miro Hrončok <mhroncok@redhat.com> - 2.6.1-1

+ - Update to 2.6.1 for pytest 4 compatibility

+ 

  * Tue Feb 12 2019 Orion Poplawski <orion@nwra.com> - 2.6.0-3

  - Build with pytest-xdist

  

file modified
+1 -1
@@ -1,1 +1,1 @@ 

- SHA512 (pytest-cov-2.6.0.tar.gz) = e77f411d1b82cad561ad2894327f56997e264e3f58e57ceaa50e0621df013c16de42e0cab122375662129e9d5f6066d12778a80db5de57b3e1e4ef8540ddc632

+ SHA512 (pytest-cov-2.6.1.tar.gz) = d277ca7cb183b0c18e126b8a6a36793fb449cb77f3058cfbcd0cea39b2bd9855e53a1a13839b7767b3d3583c1a83199a501c3c1924598946ead32981eff1c56f