%global srcname pytest-shutil
%global sum A goodie-bag of unix shell and environment tools for py.test
Name: python-%{srcname}
Version: 1.7.0
Release: 1%{?dist}
Summary: %{sum}
License: MIT
URL: https://pypi.python.org/pypi/%{srcname}
Source0: https://files.pythonhosted.org/packages/source/p/%{srcname}/%{srcname}-%{version}.tar.gz
BuildArch: noarch
BuildRequires: python2-devel python3-devel
BuildRequires: python2-pytest python3-pytest
BuildRequires: python2-six python3-six
BuildRequires: python2-setuptools-git python3-setuptools_git
BuildRequires: python2-mock python3-mock
BuildRequires: python2-path python3-path
BuildRequires: python2-contextlib2 python3-contextlib2
BuildRequires: python2-execnet python3-execnet
BuildRequires: python3-termcolor
%description
This library is a goodie-bag of Unix shell and
environment management tools for automated tests.
%package -n python2-%{srcname}
Summary: %{sum}
Recommends: %{py2_dist termcolor}
%{?python_provide:%python_provide python2-%{srcname}}
%description -n python2-%{srcname}
This library is a goodie-bag of Unix shell and
environment management tools for automated tests.
%package -n python3-%{srcname}
Summary: %{sum}
Recommends: %{py3_dist termcolor}
%{?python_provide:%python_provide python3-%{srcname}}
%description -n python3-%{srcname}
This library is a goodie-bag of Unix shell and
environment management tools for automated tests.
%prep
%autosetup -n %{srcname}-%{version} -p1
# https://bugzilla.redhat.com/show_bug.cgi?id=1702355
sed -i "/'termcolor'/d" setup.py
%build
# Upstream pins pytest to older than 4.0.0 until they finish cleaning up deprecications.
# However, we have no choice and all the tests do pass fine, so we unpin here.
sed -i -e 's|pytest<4.0.0|pytest|' setup.py
%py2_build
%py3_build
%install
%py2_install
%py3_install
%check
# test_pretty_formatter requires termcolor
PYTHONPATH=%{buildroot}%{python2_sitelib} %{__python2} -m pytest -k "not test_pretty_formatter"
PYTHONPATH=%{buildroot}%{python3_sitelib} %{__python3} -m pytest
%files -n python2-%{srcname}
%doc README.md CHANGES.md
%{python2_sitelib}/*
%files -n python3-%{srcname}
%doc README.md CHANGES.md
%{python3_sitelib}/*
%changelog
* Sun Jun 16 2019 Kevin Fenzi <kevin@scrye.com> - 1.7.0-1
- Update to 1.7.0. Fixes bug #1714449
* Tue Apr 23 2019 Miro Hrončok <mhroncok@redhat.com> - 1.6.0-2
- Only recommend termcolor (#1702355)
* Sun Apr 14 2019 Kevin Fenzi <kevin@scrye.com> - 1.6.0-1
- Update to 1.6.0. Fixes bug #1697356
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.6-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.6-4
- Rebuilt for Python 3.7
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Sat Jan 27 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.2.6-2
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Thu Jul 27 2017 Kevin Fenzi <kevin@scrye.com> - 1.2.11-2
- Add Requires for pytest
* Wed Jul 26 2017 Kevin Fenzi <kevin@scrye.com> - 1.2.11-1
- Initial version.