#3 Allow to build with Cython 3.0.5
Merged 7 months ago by iztokf. Opened 7 months ago by ksurma.
rpms/ ksurma/python-pyunicorn cython3  into  rawhide

file modified
+1 -1
@@ -60,7 +60,7 @@ 

  

  BuildRequires:  make

  BuildRequires:  gcc-c++

- BuildRequires:  Cython < 3~~

+ BuildRequires:  Cython

  

  BuildRequires:  python3-igraph

  BuildRequires:  numpy

It was possible to build python3-cangjie with Cython 3.0.5 in the test copr, hence proposal to unpin the dependency. I've checked the upstream project where they already use Cython 3 in the master branch, but it has not yet been released.

Build succeeded.
https://fedora.softwarefactory-project.io/zuul/buildset/26ac1b7ff6834fa2b826c219e285a437

Thanks, @ksurma.

@ankursinha, if you do not mind, I will merge this.

Pull-Request has been merged by iztokf

7 months ago

I submitted a build:

Building python-pyunicorn-0.7.0~a1-3.gitmaster.fc40 for rawhide
Created task: 110192203
Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=110192203

Thanks @churchyard! I assume @iztokf forgot and since the PR was merged this dropped off our radar.

Metadata