#6 Drop unwanted python-pytest-cov dependency
Merged 6 months ago by sgallagh. Opened 6 months ago by yselkowitz.
rpms/ yselkowitz/python-rpmautospec rawhide  into  rawhide

file modified
+3 -1
@@ -35,7 +35,6 @@ 

  BuildRequires: python3-devel >= 3.9.0

  # The dependencies needed for testing don’t get auto-generated.

  BuildRequires: python3dist(pytest)

- BuildRequires: python3dist(pytest-cov)

  %if %{with xdist}

  BuildRequires: python3dist(pytest-xdist)

  %endif
@@ -80,6 +79,9 @@ 

  %autopatch 100

  %endif

  

+ # https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/#_linters

+ sed -i -e '/pytest-cov/d' pyproject.toml

+ 

  %build

  %pyproject_wheel

  

Coverage checkers should not be run when building Fedora or RHEL packages:

https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/#_linters

Pull-Request has been merged by sgallagh

6 months ago
Metadata