Blob Blame History Raw
%global srcname social-auth-core
%global desc Python Social Auth is an easy to setup social \
authentication/registration mechanism with support for several frameworks and \
auth providers. This is the core component of the python-social-auth ecosystem, \
it implements the common interface to define new authentication backends to \
third parties services, implement integrations with web frameworks and storage \
solutions. \

Name:           python-%{srcname}
Version:        1.7.0
Release:        1%{?dist}
Summary:        The core component of the python-social-auth ecosystem

License:        BSD
URL:            https://pypi.python.org/pypi/%{srcname}
Source0:        https://github.com/python-social-auth/social-core/archive/%{version}/%{srcname}-%{version}.tar.gz
Patch0:         Unpin-the-test-requirements-and-use-unittest2-for-Py.patch

BuildArch:      noarch
BuildRequires:  python2-devel python3-devel


%description
%{desc}


%package -n python3-%{srcname}
Summary: %{summary}
%{?python_provide:%python_provide python3-%{srcname}}
BuildRequires: %{py3_dist cryptography}
BuildRequires: %{py3_dist unittest2}
BuildRequires: %{py3_dist nose}
BuildRequires: %{py3_dist httpretty}
BuildRequires: %{py3_dist defusedxml}
BuildRequires: %{py3_dist python3-openid}
BuildRequires: %{py3_dist python3-saml}
BuildRequires: %{py3_dist requests}
BuildRequires: %{py3_dist oauthlib}
BuildRequires: %{py3_dist requests-oauthlib}
BuildRequires: %{py3_dist six}
BuildRequires: %{py3_dist PyJWT}
Requires: %{py3_dist cryptography}
Requires: %{py3_dist defusedxml}
Requires: %{py3_dist python3-openid}
Requires: %{py3_dist python3-saml}
Requires: %{py3_dist requests}
Requires: %{py3_dist oauthlib}
Requires: %{py3_dist requests-oauthlib}
Requires: %{py3_dist six}
Requires: %{py3_dist PyJWT}


%description -n python3-%{srcname}
%{desc}


%prep
%autosetup -p1 -n social-core-%{version}
rm -f requirements-openidconnect.txt
touch requirements-openidconnect.txt
rm -f social_core/tests/requirements-base.txt
touch social_core/tests/requirements-base.txt


%build
%py3_build


%install
%py3_install


%check
%__python3 setup.py test


%files -n python3-%{srcname}
%license LICENSE
%doc README.md CHANGELOG.md
%{python3_sitelib}/*


%changelog
* Thu Jan 25 2018 Jeremy Cline <jeremy@jcline.org> - 1.7.0-1
- Initial package.