#3 Subpackage python2-sphinxcontrib-websupport has been removed + update
Merged a year ago by churchyard. Opened a year ago by churchyard.
rpms/ churchyard/python-sphinxcontrib-websupport nopy2  into  master

file modified
+1

@@ -2,3 +2,4 @@ 

  /sphinxcontrib-websupport-1.0.1.dev20171013.tar.gz

  /88d4fdd163efdeaab91a105b7980c42078ed3417.tar.gz

  /ebe84efc1a869da8d5689c706cdcf6ea864f0d9b.tar.gz

+ /sphinxcontrib-websupport-1.1.0.tar.gz

@@ -1,49 +1,19 @@ 

- %if 0%{?fedora} || 0%{?rhel} > 7

- %global with_python3 1

- %endif

- 

- %global commit ebe84efc1a869da8d5689c706cdcf6ea864f0d9b

  %global pypi_name sphinxcontrib-websupport

  

  Name:           python-%{pypi_name}

- Version:        1.0.1

- Release:        12.20180316git%{?dist}

+ Version:        1.1.0

+ Release:        1%{?dist}

  Summary:        Sphinx API for Web Apps

  

  License:        BSD

  URL:            http://sphinx-doc.org/

- Source0:        https://github.com/sphinx-doc/sphinxcontrib-websupport/archive/%{commit}.tar.gz

+ Source0:        %{pypi_source}

  BuildArch:      noarch

  

  %description

  sphinxcontrib-websupport provides a Python API to easily integrate Sphinx

  documentation into your Web application.

  

- %package -n     python2-%{pypi_name}

- Summary:        %{summary}

- %{?python_provide:%python_provide python2-%{pypi_name}}

- BuildRequires:  python2-devel

- BuildRequires:  python2-docutils

- BuildRequires:  python2-jinja2

- BuildRequires:  python2-mock

- BuildRequires:  python2-pytest

- BuildRequires:  python2-setuptools

- BuildRequires:  python2-six

- BuildRequires:  python2-sphinx

- BuildRequires:  python2-sqlalchemy

- BuildRequires:  python2-whoosh

- Requires:       python2-docutils

- Requires:       python2-jinja2

- Requires:       python2-six

- Requires:       python2-sphinx

- Requires:       python2-sqlalchemy

- Requires:       python2-whoosh

- 

- %description -n python2-%{pypi_name}

- sphinxcontrib-websupport provides a Python API to easily integrate Sphinx

- documentation into your Web application.

- 

- %if 0%{?with_python3}

  %package -n     python3-%{pypi_name}

  Summary:        %{summary}

  %{?python_provide:%python_provide python3-%{pypi_name}}

@@ -67,48 +37,35 @@ 

  %description -n python3-%{pypi_name}

  sphinxcontrib-websupport provides a Python API to easily integrate Sphinx

  documentation into your Web application.

- %endif

  

  %prep

- %autosetup -n %{pypi_name}-%{commit}

+ %autosetup -n %{pypi_name}-%{version}

  # Remove bundled egg-info

  rm -rf %{pypi_name}.egg-info

  

  %build

- %if 0%{?with_python3}

  %py3_build

- %endif

- %py2_build

  

  %install

- %if 0%{?with_python3}

  %py3_install

- %endif

- %py2_install

  

  %check

- PYTHONPATH=. py.test tests/

- %if 0%{?with_python3}

  PYTHONPATH=. py.test-3 tests/

- %endif

  

- %files -n python2-%{pypi_name}

- %license LICENSE

- %doc README.rst

- %{python2_sitelib}/sphinxcontrib/websupport

- %{python2_sitelib}/sphinxcontrib_websupport-*.pth

- %{python2_sitelib}/sphinxcontrib_websupport-*.egg-info

- 

- %if 0%{?with_python3}

  %files -n python3-%{pypi_name}

  %license LICENSE

  %doc README.rst

- %{python3_sitelib}/sphinxcontrib/websupport

+ %dir %{python3_sitelib}/sphinxcontrib

+ %{python3_sitelib}/sphinxcontrib/websupport/

  %{python3_sitelib}/sphinxcontrib_websupport-*.pth

  %{python3_sitelib}/sphinxcontrib_websupport-*.egg-info

- %endif

  

  %changelog

+ * Wed Mar 06 2019 Miro Hrončok <mhroncok@redhat.com> - 1.1.0-1

+ - Update to 1.1.0

+ - Subpackage python2-sphinxcontrib-websupport has been removed

+   See https://fedoraproject.org/wiki/Changes/Sphinx2

+ 

  * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-12.20180316git

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

  

file modified
+1 -1

@@ -1,1 +1,1 @@ 

- SHA512 (ebe84efc1a869da8d5689c706cdcf6ea864f0d9b.tar.gz) = a33c32cd20c24a714c149059953492e2bacf590a912cc2144935021ad4c2639eb7a47986f31bebf028bcc43de3a842bde0215602213d883d3cc0ed9abf78e747

+ SHA512 (sphinxcontrib-websupport-1.1.0.tar.gz) = adbd7db06150a4424a881a22442c2535ed823c7adcc295ef9c3af5ae38d823349830a114e8a7af2138498d0e68b37189707c1bb5a28b45c76031bcf94210fb89

https://fedoraproject.org/wiki/Changes/Sphinx2

The tests are failing with previous version and with 1.1.0 alike. Not sure what's going on.

I was unlucky even updating to git master. The tests fail with sphinx 1.8.x and 2.0.x alike.

I will disable them just to get rid of the subpackage and enable them again.

I plan to do that on Monday so if somebody has a better "fix", please do tell.

Pull-Request has been merged by churchyard

a year ago