#6 update to version 0.7.0
Merged a year ago by churchyard. Opened a year ago by decathorpe.
Unknown source master  into  master

file modified
+1
@@ -11,3 +11,4 @@

  /tomlkit-0.5.8.tar.gz

  /tomlkit-0.5.10.tar.gz

  /tomlkit-0.5.11.tar.gz

+ /tomlkit-0.7.0.tar.gz

file modified
+7 -4
@@ -1,8 +1,8 @@

  diff --git a/setup.py b/setup.py

- index eeebc16..8a4fb71 100644

+ index 576420d..31b54dc 100644

  --- a/setup.py

  +++ b/setup.py

- @@ -2,18 +2,7 @@

+ @@ -2,21 +2,7 @@

   from setuptools import setup

   

   packages = \
@@ -13,6 +13,9 @@

  - 'tests': ['examples/*',

  -           'examples/invalid/*',

  -           'examples/json/*',

+ -           'toml-spec-tests/*',

+ -           'toml-spec-tests/errors/*',

+ -           'toml-spec-tests/values/*',

  -           'toml-test/*',

  -           'toml-test/tests/*',

  -           'toml-test/tests/invalid-encoder/*',
@@ -22,11 +25,11 @@

   

   extras_require = \

   {':python_version >= "2.7" and python_version < "2.8"': ['enum34>=1.1,<2.0',

- @@ -31,7 +20,6 @@ setup_kwargs = {

+ @@ -34,7 +20,6 @@ setup_kwargs = {

       'maintainer_email': None,

       'url': 'https://github.com/sdispater/tomlkit',

       'packages': packages,

  -    'package_data': package_data,

       'extras_require': extras_require,

-      'python_requires': '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',

+      'python_requires': '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',

   }

file modified
+8 -2
@@ -17,8 +17,8 @@

  

  Name:           python-%{pypi_name}

  Summary:        Style preserving TOML library

- Version:        0.5.11

- Release:        3%{?dist}

+ Version:        0.7.0

+ Release:        1%{?dist}

  License:        MIT

  

  URL:            https://github.com/sdispater/tomlkit
@@ -31,7 +31,10 @@

  

  BuildRequires:  python3-devel

  BuildRequires:  python3dist(setuptools)

+ 

+ # test dependencies

  BuildRequires:  python3dist(pytest)

+ BuildRequires:  python3dist(pyyaml)

  

  %description %{common_description}

  
@@ -68,6 +71,9 @@

  

  

  %changelog

+ * Sat Oct 03 2020 Fabio Valentini <decathorpe@gmail.com> - 0.7.0-1

+ - Update to version 0.7.0.

+ 

  * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.11-3

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

  

file modified
+1 -1
@@ -1,1 +1,1 @@

- SHA512 (tomlkit-0.5.11.tar.gz) = 8577ce5a44427ceb3a7f7612cd4cd1fde42a6bc4e8a54508be3ff8f6160ce32e71556794135240af6ec59bdc3b785ab2dfffe43c2205dc7aa1bc796183a95610

+ SHA512 (tomlkit-0.7.0.tar.gz) = 1483dbc3a8cf87257d592b5af97a66449133337b5a6f709d997054861615527510338fa27f048b27a69611782bd35a126c750eee465301d92e83cd2a8e45c5a5

  • update to latest version (0.5.11 → 0.7.0)
  • rebase setup.py fixes patch
  • add new yaml dependency for test suite

Required for poetry 1.1.0:
https://src.fedoraproject.org/rpms/poetry/pull-request/4

Build succeeded.

Pull-Request has been merged by churchyard

a year ago