Blame python-wled.spec

2cb4dcf
%global pypi_name wled
2cb4dcf
2cb4dcf
Name:           python-%{pypi_name}
2cb4dcf
Version:        0.4.4
2cb4dcf
Release:        2%{?dist}
2cb4dcf
Summary:        Python client for WLED
2cb4dcf
2cb4dcf
License:        MIT
2cb4dcf
URL:            https://github.com/frenck/python-wled
2cb4dcf
Source0:        %{url}/archive/v%{version}/%{pypi_name}-%{version}.tar.gz
2cb4dcf
BuildArch:      noarch
2cb4dcf
2cb4dcf
%description
2cb4dcf
This package allows you to control and monitor an WLED device
2cb4dcf
programmatically. It is mainly created to allow third-party
2cb4dcf
programs to automate the behavior of WLED.
2cb4dcf
2cb4dcf
%package -n     python3-%{pypi_name}
2cb4dcf
Summary:        %{summary}
2cb4dcf
2cb4dcf
BuildRequires:  python3-devel
2cb4dcf
BuildRequires:  %{py3_dist aiohttp}
2cb4dcf
BuildRequires:  %{py3_dist attrs}
2cb4dcf
BuildRequires:  %{py3_dist setuptools}
2cb4dcf
BuildRequires:  %{py3_dist yarl}
2cb4dcf
BuildRequires:  %{py3_dist pytest}
2cb4dcf
BuildRequires:  %{py3_dist backoff}
2cb4dcf
BuildRequires:  %{py3_dist aresponses}
2cb4dcf
BuildRequires:  %{py3_dist pytest-asyncio}
2cb4dcf
2cb4dcf
%description -n python3-%{pypi_name}
2cb4dcf
This package allows you to control and monitor an WLED device
2cb4dcf
programmatically. It is mainly created to allow third-party
2cb4dcf
programs to automate the behavior of WLED.
2cb4dcf
2cb4dcf
%prep
2cb4dcf
%autosetup -n python-%{pypi_name}-%{version}
2cb4dcf
rm -rf %{pypi_name}.egg-info
2cb4dcf
2cb4dcf
%build
2cb4dcf
%py3_build
2cb4dcf
2cb4dcf
%install
2cb4dcf
%py3_install
2cb4dcf
2cb4dcf
%check
2cb4dcf
%pytest -v tests
2cb4dcf
%files -n python3-%{pypi_name}
2cb4dcf
%license LICENSE.md
2cb4dcf
%doc README.md
2cb4dcf
%{python3_sitelib}/%{pypi_name}/
2cb4dcf
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info/
2cb4dcf
2cb4dcf
%changelog
2cb4dcf
* Wed Jan 20 2020 Fabian Affolter <mail@fabian-affolter.ch> - 0.4.4-2
2cb4dcf
- Update to new macros (#1903509)
2cb4dcf
2cb4dcf
* Wed Dec 02 2020 Fabian Affolter <mail@fabian-affolter.ch> - 0.4.4-1
2cb4dcf
- Initial package