Blob Blame Raw
%global modname zope.schema

Summary: Zope 3 schemas
Name: python-zope-schema
Version: 3.7.0
Release: 1%{?dist}
Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.zip
License: ZPLv2.1
Group: Development/Libraries
BuildArch: noarch
URL: http://pypi.python.org/pypi/zope.schema

BuildRequires: python2-devel
BuildRequires: python-setuptools
# For tests
BuildRequires: python-zope-testing
BuildRequires: python-zope-interface
BuildRequires: python-zope-event

Requires: python-zope-interface
# python-zope-event is noarch
Requires: python-zope-event

%description
This package is a zope.interface extension for defining data schemas.

%prep
%setup -q -n %{modname}-%{version}

%build
python setup.py build

%install
%{__python} setup.py install --root=$RPM_BUILD_ROOT

%check
%{__python} setup.py test

%files
%defattr(-,root,root,-)
%doc LICENSE.txt CHANGES.txt COPYRIGHT.txt src/zope/schema/*.txt
%{python_sitelib}/zope/schema/
%exclude %{python_sitelib}/zope/schema/tests/
%exclude %{python_sitelib}/zope/schema/*.txt
%{python_sitelib}/%{modname}-*.egg-info
%{python_sitelib}/%{modname}-*-nspkg.pth


%changelog
* Thu Sep 16 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.7.0-1
- Update to 3.7.0
- Move the documents to proper place
- Exclude the tests

* Sat Sep 11 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.6.4-2
- Spec cleaned up
- Requires: python-zope-filesystem and python-setuptools removed
- Add %%check section and run tests
- BR: python-zope-testing and runtime requirements added
- Don't move the text files

* Wed Jun 16 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.6.4-1
- Initial packaging