#3 Upstream release 2.3
Merged 4 months ago by tdawson. Opened 5 months ago by lbalhar.
rpms/ lbalhar/python3-cryptography epel7  into  epel7

file modified
+29 -30

@@ -5,29 +5,23 @@ 

  and recipes to Python developers.

  

  Name:           python3-%{pkgname}

- Version:        1.7.2

- Release:        4%{?dist}

+ Version:        2.3

+ Release:        1%{?dist}

  Summary:        %{sum}

  

  Group:          Development/Libraries

  License:        ASL 2.0 or BSD

  URL:            https://cryptography.io/en/latest/

  Source0:        https://pypi.io/packages/source/c/cryptography/cryptography-%{version}.tar.gz

- Patch0:         0001-Drop-minimal-setuptools-and-pytest-version-fron-setu.patch

- Patch1:         0002-Disable-unsupported-tests.patch

- Patch2:         0003-Refactor-binding-initialization-to-allow-specified-e.patch

- Patch3:         0004-Enlarge-_oid2txt-buffer-to-handle-larger-OIDs-3612.patch

  

- # Patch from https://github.com/pyca/cryptography/pull/3328

- Patch10:        add_memory_limit.patch

+ Patch0001:      0001-Fixed-4380-do-not-assume-TLSv1-is-available-in-OpenS.patch

+ Patch0002:      0002-Remove-pytest-version-limit.patch

  

  BuildRequires:  openssl-devel

- 

- BuildRequires:  python-srpm-macros

+ BuildRequires:  gcc

  

  %description %{pkgdesc}

  

- 

  %if %{python3_pkgversion} != 3

  %package -n  python%{python3_pkgversion}-%{pkgname}

  Group:          Development/Libraries

@@ -39,20 +33,18 @@ 

  BuildRequires:  python%{python3_pkgversion}-pretend

  BuildRequires:  python%{python3_pkgversion}-iso8601

  BuildRequires:  python%{python3_pkgversion}-cryptography-vectors = %{version}

- BuildRequires:  python%{python3_pkgversion}-pyasn1-modules >= 0.1.8

- BuildRequires:  python%{python3_pkgversion}-hypothesis

+ BuildRequires:  python%{python3_pkgversion}-asn1crypto >= 0.21

+ BuildRequires:  python%{python3_pkgversion}-hypothesis >= 1.11.4

  BuildRequires:  python%{python3_pkgversion}-pytz

- BuildRequires:  python%{python3_pkgversion}-idna >= 2.0

- BuildRequires:  python%{python3_pkgversion}-pyasn1 >= 0.1.8

+ BuildRequires:  python%{python3_pkgversion}-idna >= 2.1

  BuildRequires:  python%{python3_pkgversion}-six >= 1.4.1

- BuildRequires:  python%{python3_pkgversion}-cffi >= 1.4.1

+ BuildRequires:  python%{python3_pkgversion}-cffi >= 1.7

  %{?python_provide:%python_provide python%{python3_pkgversion}-%{pkgname}}

- Requires:       openssl

- Requires:       python%{python3_pkgversion}-idna >= 2.0

- Requires:       python%{python3_pkgversion}-pyasn1 >= 0.1.8

+ Requires:       openssl-libs

+ Requires:       python%{python3_pkgversion}-idna >= 2.1

+ Requires:       python%{python3_pkgversion}-asn1crypto >= 0.21

  Requires:       python%{python3_pkgversion}-six >= 1.4.1

- Requires:       python%{python3_pkgversion}-cffi >= 1.4.1

- Requires:       python%{python3_pkgversion}-setuptools

+ Requires:       python%{python3_pkgversion}-cffi >= 1.7

  

  %description -n python%{python3_pkgversion}-%{pkgname} %{pkgdesc}

  %endif

@@ -69,19 +61,18 @@ 

  BuildRequires:  python%{python3_other_pkgversion}-pretend

  BuildRequires:  python%{python3_other_pkgversion}-iso8601

  BuildRequires:  python%{python3_other_pkgversion}-cryptography-vectors = %{version}

- BuildRequires:  python%{python3_other_pkgversion}-pyasn1-modules >= 0.1.8

- BuildRequires:  python%{python3_other_pkgversion}-hypothesis

+ BuildRequires:  python%{python3_other_pkgversion}-asn1crypto >= 0.21

+ BuildRequires:  python%{python3_other_pkgversion}-hypothesis >= 1.11.4

  BuildRequires:  python%{python3_other_pkgversion}-pytz

- BuildRequires:  python%{python3_other_pkgversion}-idna >= 2.0

- BuildRequires:  python%{python3_other_pkgversion}-pyasn1 >= 0.1.8

+ BuildRequires:  python%{python3_other_pkgversion}-idna >= 2.1

  BuildRequires:  python%{python3_other_pkgversion}-six >= 1.4.1

- BuildRequires:  python%{python3_other_pkgversion}-cffi >= 1.4.1

+ BuildRequires:  python%{python3_other_pkgversion}-cffi >= 1.7

  %{?python_provide:%python_provide python%{python3_other_pkgversion}-%{pkgname}}

- Requires:       openssl

- Requires:       python%{python3_other_pkgversion}-idna >= 2.0

- Requires:       python%{python3_other_pkgversion}-pyasn1 >= 0.1.8

+ Requires:       openssl-libs

+ Requires:       python%{python3_other_pkgversion}-idna >= 2.1

+ Requires:       python%{python3_other_pkgversion}-asn1crypto >= 0.21

  Requires:       python%{python3_other_pkgversion}-six >= 1.4.1

- Requires:       python%{python3_other_pkgversion}-cffi >= 1.4.1

+ Requires:       python%{python3_other_pkgversion}-cffi >= 1.7

  

  %description -n python%{python3_other_pkgversion}-%{pkgname} %{pkgdesc}

  %endif

@@ -110,6 +101,9 @@ 

  

  

  %check

+ # workaround for pytest 3.2.0 bug https://github.com/pytest-dev/pytest/issues/2644

+ rm -f tests/hazmat/primitives/test_padding.py

+ 

  %{__python3} setup.py test

  %if 0%{?with_python3_other}

  %{__python3_other} setup.py test

@@ -130,6 +124,11 @@ 

  

  

  %changelog

+ * Thu Feb 07 2019 Lumír Balhar <lbalhar@redhat.com> - 2.3-1

+ - Upstream release 2.3

+ - Spec manually merged from F30 to fix FTBFS in epel7

+ - New Patch0002 to remove pytest version limit from setup.py

+ 

  * Wed Jul 25 2018 Aurelien Bompard <abompard@fedoraproject.org> - 1.7.2-4

  - Add missing Requires (BZ#1598877)

  

Hello.

We are working on making Python 3.6 the default Python in epel7. When we were trying to rebuild all packages with the new Python, we discovered that python3-cryptography fails to build from source because there is an incompatibility with the python-idna. python-idna was updated from 2.1 to 2.7 in September.

IDNA incompatibilities were causing a lot of troubles in cryptography so the cryptography developers decided to drop IDNA in the most recent version.

IDNA version in epel7 is too new for cryptography 1.7.2. I tried to update cryptography only to 1.9 but the problem persisted so then I decided to update it to the latest version in Fedora and it seems good. As you can see in copr repo with Python 3.6, also all dependent packages build without troubles and I also did some testing manually.

I'll open another PR for cryptography-vectors which you can also see in linked coprs.

What do you think about it?

cryptography upstream changelog: https://github.com/pyca/cryptography/blob/master/CHANGELOG.rst
idna upstream releases: https://github.com/kjd/idna/releases
epel7 copr with Python 3.6: https://copr.fedorainfracloud.org/coprs/g/python/epel-python3/builds/
current epel7 copr: https://copr.fedorainfracloud.org/coprs/lbalhar/cryptography-2.3/builds/

The python36 update it the right time to merge this, merging.

Pull-Request has been merged by tdawson

4 months ago
Metadata