#1 Don't drag in Python 2 via sip-devel
Merged 3 years ago by limb. Opened 3 years ago by churchyard.
rpms/ churchyard/python3-poppler-qt5 py3  into  master

file modified
+4 -2
@@ -1,6 +1,6 @@ 

  Name:           python3-poppler-qt5

  Version:        0.24.2

- Release:        9%{?dist}

+ Release:        10%{?dist}

  Summary:        Python bindings for the Poppler PDF rendering library

  

  License:        LGPLv2+
@@ -13,7 +13,6 @@ 

  BuildRequires:  python3-qt5-devel

  BuildRequires:  python3-sip-devel >= 4.9.1

  BuildRequires:  pkgconfig(poppler-qt5)

- BuildRequires:  sip-devel

  

  # we don't want to provide private python extension libs

  %{?filter_setup:
@@ -47,6 +46,9 @@ 

  %{python3_sitearch}/python_poppler*

  

  %changelog

+ * Mon Dec 10 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.2-10

+ - Don't drag in Python 2 via sip-devel

+ 

  * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.2-9

  - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

  

no initial comment

Still requires sip-api(12) >= 12.5 and that is provided by python2-sip. python3-sip does not provide it.

Pull-Request has been merged by limb

3 years ago