Blob Blame History Raw
Name:           reposurgeon
Version:        3.10
Release:        1%{?dist}
Summary:        SCM Repository Manipulation Tool
License:        BSD
URL:            http://www.catb.org/~esr/reposurgeon/
Source0:        http://www.catb.org/~esr/reposurgeon/%{name}-%{version}.tar.gz
BuildArch:      noarch
BuildRequires:  asciidoc
BuildRequires:  python
BuildRequires:  xmlto
Requires:       python

%description
Reposurgeon enables risky operations that version-control systems don't want 
to let you do, such as editing past comments and metadata and removing 
commits. It works with any version control system that can export and import 
git fast-import streams, including git, hg, and bzr.

%prep
%setup -q

%build
make %{?_smp_mflags}

%install
make install INSTALL="install -p" target="%{buildroot}%{_prefix}"
# We use %%doc to install docs.
rm -rfv %{buildroot}%{_docdir}

%check
make check

%files
%doc AUTHORS COPYING NEWS README TODO features.html
%{_bindir}/%{name}
%{_bindir}/repopuller
%{_bindir}/repodiffer
%{_mandir}/man1/%{name}.1*
%{_mandir}/man1/repodiffer.1*
%{_mandir}/man1/repopuller.1*

%changelog
* Tue Apr 22 2014 Christopher Meng <rpm@cicku.me> - 3.10-1
- Finer control over filtering with caC flags.
- New setfield command for tweaking object attributes from lift scripts.
- The attribution-parsing code handles odd characters in names better now. 
- The filter command can operate on email addresses as well as names.
- New 'stamp' command to report action stamps of commits.
- New 'count' comment reports selection-set counts.
- New branchify_mapping option for renaming Subversion branches on analysis.
- New transcode command for moving metadata to UTF-8.
- New @dsc() function for selecting all descendants of a selection set.

* Fri Mar 21 2014 Christopher Meng <rpm@cicku.me> - 3.7-1
- New --dedos option for filter command, to change \r\n line endings to \n.
- New append command for annotating comments.
- The 'b' search code has been changed to appropriately match non-commits.
- New form of 'graft' allows greater control over graft points.
- New =I selector to find non-UTF-8 commit metadata.
- Import stream comments led with # are preserved as passthroughs.
- Buggy text search of authors fields has been fixed.

* Thu Feb 20 2014 Christopher Meng <rpm@cicku.me> - 3.6-1
- Major rewrite of the generic conversion makefile.
- Fixed a bug in the graft and unite commands.
- Single fossil or tag names now select as if surrounded by <>.
- Fixed more bugs in debranch.
- @amp() function useful for logic-gating in conjunctive expressions.
- New 'assign' command allows precomputation of expensive selections.
- There's an 'unassign' as well.
- exec/eval facility for custom Python extensions.
- path rename has a --relax and --force options to deal with oath collisions
- New --changelog option of coalesce can recognize FSF-style ChangeLog files.

* Thu Feb 13 2014 Christopher Meng <rpm@cicku.me> - 3.3-1
- Set negation in selections with ~.
- @min() and @max() in selections.
- 'define' by itself lists macros.
- New 'deletes' option in the remove command.

* Wed Feb 05 2014 Christopher Meng <rpm@cicku.me> - 3.2-1
- New path rename command.
- List and inspect now take either a leading or following selection.
- Text search selections can now have a B suffix to search blobs.
- Now possible to transplant fileops between commits using remove .. to.
- A date of the form <YYYY-mm-dd> selects all commits and tags that day.
- Macros can now be multiline.
- The filter command now has a --replace modifier to avoid regex overhead.
- Associated branches are renamed when a reset or tag is moved or deleted.
- Bug fix for off-by-one error in tags reporting.
- Many syntactic features of the language have changed incompatibly.
- Backward-incompatible language changes are documented on the manual page.
- 'expunge' and 'unite' commands have been incompatibly improved.
- New 'strip' command for generating test cases with blobs stripped out
- New 'reduce' command for topological reduction of test cases.
- The 'lint' command gets a test for the existence of multiple roots.
- Selecting a date or action stamp matching multiple commits now matches all.
- The surgical language now has a macro facility.
- "set canonicalize" is now effective during import stream reads.
- Introduced =O, =M, =F selectors for parentless, merge, and fork commits.
- The "multiline" modifier on edit is replaced by the =L selector.
- Selection-set evaluation now short-circuits predicates and is faster.
- Fixed a buggy test that caused the reader to choke on submodule links.

* Thu Nov 21 2013 Christopher Meng <rpm@cicku.me> - 2.42-1
- Prevented crash when tagifying a mixed-branch commit.
- svn_no_autoignores -> svn_noautoignores.
- Ignore single-rev mergeinfos in Subversion, they're cherry-picks.

* Sat Nov 09 2013 Christopher Meng <rpm@cicku.me> - 2.41-1
- Fixed a fatal bug when reading any symlink from a live Subversion repo.
- Added svn_no_autoignores option.

* Thu Aug 08 2013 Christopher Meng <rpm@cicku.me> - 2.40-1
- Update to new release.
- Improvements in .gitignore processing.

* Wed May 29 2013 Christopher Meng <rpm@cicku.me> - 2.39-2
- Add parallel make support.

* Fri May 24 2013 Christopher Meng <rpm@cicku.me> - 2.39-1
- New 'tagify' command for tagifying empty commits.
- Correctness fixes for deletion edge cases.

* Fri May 10 2013 Christopher Meng <rpm@cicku.me> - 2.38-1
- Significant improvements to Subversion branch link detection.
- New 'reparent' command for modifying the DAG.
- Fixes for two minor crash bugs in handling of malformed commands.


* Fri Apr 26 2013 Christopher Meng <rpm@cicku.me> - 2.37-1
- No more tree pollution on branches deduced from file copies.

* Sun Apr 21 2013 Christopher Meng <rpm@cicku.me> - 2.35-1
- New "manifest" command.
- Path-matching now has @ to require all paths in a commit to match.

* Wed Apr 17 2013 Christopher Meng <rpm@cicku.me> - 2.33-1
- Update to new release.

* Sun Apr 07 2013 Christopher Meng <rpm@cicku.me> - 2.32-1
- Initial package.