#1 Replace 'urw-fonts' requirements with 'urw-base35-fonts'
Closed 4 years ago by ellert. Opened 4 years ago by dkaspar.
Unknown source master  into  master

file modified
+2 -2
@@ -207,7 +207,7 @@

  BuildRequires:	font(freeserif)

  BuildRequires:	font(freemono)

  #		Provides "symbol", "dingbats" and "chancery"

- BuildRequires:	urw-fonts

+ BuildRequires:	urw-base35-fonts

  #		The root-fonts package provides Droid Sans Fallback for EPEL

  %if %{?fedora}%{!?fedora:0} >= 11

  BuildRequires:	font(droidsansfallback)
@@ -331,7 +331,7 @@

  Requires:	font(freeserif)

  Requires:	font(freemono)

  #		Provides "symbol", "dingbats" and "chancery"

- Requires:	urw-fonts

+ Requires:	urw-base35-fonts

  #		The root-fonts package provides Droid Sans Fallback for EPEL

  %if %{?fedora}%{!?fedora:0} >= 11

  Requires:	font(droidsansfallback)

The 'urw-fonts' package is now obsolete, and it will be dropped at EOL of F27.

Simply replacing urw-fonts with urw-base35-fonts makes the spec file no longer build on Fedora 26 and EPEL 7, so this needs to be conditionalized. The required changes were committed for the latest update. Closing.

Pull-Request has been closed by ellert

4 years ago

Hello Mattias,
I'm OK with that. Thanks! ;)

Metadata