Blob Blame Raw
From 00d51625fca26938eab9c1a0f2f7e83227ea3559 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Pavel=20=C5=A0imerda?= <pavlix@pavlix.net>
Date: Wed, 5 Oct 2016 10:52:37 +0000
Subject: [PATCH 1/2] make osbs dependency optional
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Pavel Šimerda <pavlix@pavlix.net>
---
 pyrpkg/__init__.py | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/pyrpkg/__init__.py b/pyrpkg/__init__.py
index 66dd7e2..bdd7f70 100644
--- a/pyrpkg/__init__.py
+++ b/pyrpkg/__init__.py
@@ -27,8 +27,11 @@ import sys
 import tempfile
 import koji.ssl.SSLCommon
 
-from osbs.api import OSBS
-from osbs.conf import Configuration
+try:
+    from osbs.api import OSBS
+    from osbs.conf import Configuration
+except ImportError:
+    pass
 from six.moves import configparser
 from six.moves import urllib
 
-- 
2.7.5