Blob Blame History Raw
# Generated by rust2rpm 24
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}

%global crate actix-rt

Name:           rust-actix-rt
Version:        2.9.0
Release:        %autorelease
Summary:        Tokio-based single-threaded async runtime for the Actix ecosystem

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/actix-rt
Source:         %{crates_source}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Tokio-based single-threaded async runtime for the Actix ecosystem.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGES.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+actix-macros-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+actix-macros-devel %{_description}

This package contains library source intended for building other packages which
use the "actix-macros" feature of the "%{crate}" crate.

%files       -n %{name}+actix-macros-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+io-uring-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+io-uring-devel %{_description}

This package contains library source intended for building other packages which
use the "io-uring" feature of the "%{crate}" crate.

%files       -n %{name}+io-uring-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+macros-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+macros-devel %{_description}

This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.

%files       -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio-uring-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-uring-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio-uring" feature of the "%{crate}" crate.

%files       -n %{name}+tokio-uring-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog