Blob Blame History Raw
# Generated by rust2rpm 25
# * tests can only be run in-tree
%bcond_with check
%global debug_package %{nil}

%global crate actix-web

Name:           rust-actix-web
Version:        4.4.1
Release:        %autorelease
Summary:        Powerful, pragmatic, and extremely fast web framework for Rust

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/actix-web
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused support for rustls
Patch:          actix-web-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Actix Web is a powerful, pragmatic, and extremely fast web framework for
Rust.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGES.md
%doc %{crate_instdir}/MIGRATION-0.x.md
%doc %{crate_instdir}/MIGRATION-1.0.md
%doc %{crate_instdir}/MIGRATION-2.0.md
%doc %{crate_instdir}/MIGRATION-3.0.md
%doc %{crate_instdir}/MIGRATION-4.0.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+__compress-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+__compress-devel %{_description}

This package contains library source intended for building other packages which
use the "__compress" feature of the "%{crate}" crate.

%files       -n %{name}+__compress-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+actix-macros-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+actix-macros-devel %{_description}

This package contains library source intended for building other packages which
use the "actix-macros" feature of the "%{crate}" crate.

%files       -n %{name}+actix-macros-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+actix-tls-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+actix-tls-devel %{_description}

This package contains library source intended for building other packages which
use the "actix-tls" feature of the "%{crate}" crate.

%files       -n %{name}+actix-tls-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+actix-web-codegen-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+actix-web-codegen-devel %{_description}

This package contains library source intended for building other packages which
use the "actix-web-codegen" feature of the "%{crate}" crate.

%files       -n %{name}+actix-web-codegen-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+compress-brotli-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+compress-brotli-devel %{_description}

This package contains library source intended for building other packages which
use the "compress-brotli" feature of the "%{crate}" crate.

%files       -n %{name}+compress-brotli-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+compress-gzip-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+compress-gzip-devel %{_description}

This package contains library source intended for building other packages which
use the "compress-gzip" feature of the "%{crate}" crate.

%files       -n %{name}+compress-gzip-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+compress-zstd-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+compress-zstd-devel %{_description}

This package contains library source intended for building other packages which
use the "compress-zstd" feature of the "%{crate}" crate.

%files       -n %{name}+compress-zstd-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cookie-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cookie-devel %{_description}

This package contains library source intended for building other packages which
use the "cookie" feature of the "%{crate}" crate.

%files       -n %{name}+cookie-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cookies-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cookies-devel %{_description}

This package contains library source intended for building other packages which
use the "cookies" feature of the "%{crate}" crate.

%files       -n %{name}+cookies-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+experimental-io-uring-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+experimental-io-uring-devel %{_description}

This package contains library source intended for building other packages which
use the "experimental-io-uring" feature of the "%{crate}" crate.

%files       -n %{name}+experimental-io-uring-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+http2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+http2-devel %{_description}

This package contains library source intended for building other packages which
use the "http2" feature of the "%{crate}" crate.

%files       -n %{name}+http2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+macros-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+macros-devel %{_description}

This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.

%files       -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+openssl-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+openssl-devel %{_description}

This package contains library source intended for building other packages which
use the "openssl" feature of the "%{crate}" crate.

%files       -n %{name}+openssl-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+secure-cookies-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+secure-cookies-devel %{_description}

This package contains library source intended for building other packages which
use the "secure-cookies" feature of the "%{crate}" crate.

%files       -n %{name}+secure-cookies-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog