Blob Blame History Raw
# Generated by rust2rpm 25
%bcond_without check

%global crate askalono-cli

Name:           rust-askalono-cli
Version:        0.4.6
Release:        %autorelease
Summary:        Tool to detect the contents of license files

# * askalono-cli: Apache-2.0
# * spdx/license-list-data: CC0-1.0
License:        Apache-2.0 AND CC0-1.0
URL:            https://crates.io/crates/askalono-cli
Source:         %{crates_source}
# updated SPDX license list data; generated with:
# $ git clone https://github.com/spdx/license-list-data.git spdx-license-list -b v3.22 --depth 1
# $ askalono cache load-spdx spdx-license-list/json/details
# $ mv askalono-cache.bin.zstd askalono-cache-3.22.bin.zstd
Source:         askalono-cache-3.22.bin.zstd

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A tool to detect the contents of license files.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
# Apache-2.0
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# MIT
# MIT OR Apache-2.0
# MIT OR Apache-2.0 OR Zlib
# Unlicense OR MIT
# Zlib OR Apache-2.0 OR MIT
License:        Apache-2.0 AND CC0-1.0 MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (MIT OR Apache-2.0 OR Zlib) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown

Provides:       bundled(spdx-license-list-data) = 3.22

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%license NOTICE
%license LICENSE.dependencies
%doc README.md
%{_bindir}/askalono

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# update bundled SPDX license list data
cp -pav %{SOURCE1} embedded-cache.bin.zstd

%generate_buildrequires
%cargo_generate_buildrequires -f diagnostics

%build
%cargo_build -f diagnostics
%{cargo_license_summary -f diagnostics}
%{cargo_license -f diagnostics} > LICENSE.dependencies

%install
%cargo_install -f diagnostics

%if %{with check}
%check
%cargo_test -f diagnostics
%endif

%changelog
%autochangelog