Blob Blame History Raw
# Generated by rust2rpm 20
# * tests are broken: https://github.com/gtk-rs/gtk-rs-core/issues/64
%bcond_with check
%global debug_package %{nil}

%global crate atk-sys

Name:           rust-%{crate}
Version:        0.15.1
Release:        %autorelease
Summary:        FFI bindings to libatk-1

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/atk-sys
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging

%global _description %{expand:
FFI bindings to libatk-1.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(atk) >= 2.18

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license LICENSE
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+dox-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dox-devel %{_description}

This package contains library source intended for building other packages which
use the "dox" feature of the "%{crate}" crate.

%files       -n %{name}+dox-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_30-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(atk) >= 2.30

%description -n %{name}+v2_30-devel %{_description}

This package contains library source intended for building other packages which
use the "v2_30" feature of the "%{crate}" crate.

%files       -n %{name}+v2_30-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_32-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(atk) >= 2.32

%description -n %{name}+v2_32-devel %{_description}

This package contains library source intended for building other packages which
use the "v2_32" feature of the "%{crate}" crate.

%files       -n %{name}+v2_32-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v2_34-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(atk) >= 2.34

%description -n %{name}+v2_34-devel %{_description}

This package contains library source intended for building other packages which
use the "v2_34" feature of the "%{crate}" crate.

%files       -n %{name}+v2_34-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires
echo 'pkgconfig(atk) >= 2.18'

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog