Blob Blame History Raw
# Generated by rust2rpm 25
# * tests are not compatible with a stable version of rspec
%bcond_with check
%global debug_package %{nil}

%global crate colored

Name:           rust-colored
Version:        2.1.0
Release:        %autorelease
Summary:        Most simple way to add colors in your terminal

License:        MPL-2.0
URL:            https://crates.io/crates/colored
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          colored-fix-metadata-auto.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
The most simple way to add colors in your terminal.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+no-color-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+no-color-devel %{_description}

This package contains library source intended for building other packages which
use the "no-color" feature of the "%{crate}" crate.

%files       -n %{name}+no-color-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog