Blob Blame History Raw
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate diesel

Name:           rust-diesel
Version:        2.1.4
Release:        %autorelease
Summary:        Safe, extensible ORM and Query Builder for PostgreSQL, SQLite, and MySQL

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/diesel
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unavailable "libsqlite3-sys/bundled_bindings" dependency
Patch:          diesel-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A safe, extensible ORM and Query Builder for PostgreSQL, SQLite, and
MySQL.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+128-column-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+128-column-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "128-column-tables" feature of the "%{crate}" crate.

%files       -n %{name}+128-column-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+32-column-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+32-column-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "32-column-tables" feature of the "%{crate}" crate.

%files       -n %{name}+32-column-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+64-column-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+64-column-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "64-column-tables" feature of the "%{crate}" crate.

%files       -n %{name}+64-column-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bitflags-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bitflags-devel %{_description}

This package contains library source intended for building other packages which
use the "bitflags" feature of the "%{crate}" crate.

%files       -n %{name}+bitflags-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+byteorder-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+byteorder-devel %{_description}

This package contains library source intended for building other packages which
use the "byteorder" feature of the "%{crate}" crate.

%files       -n %{name}+byteorder-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+chrono-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+chrono-devel %{_description}

This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.

%files       -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+huge-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+huge-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "huge-tables" feature of the "%{crate}" crate.

%files       -n %{name}+huge-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+i-implement-a-third-party-backend-and-opt-into-breaking-changes-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+i-implement-a-third-party-backend-and-opt-into-breaking-changes-devel %{_description}

This package contains library source intended for building other packages which
use the "i-implement-a-third-party-backend-and-opt-into-breaking-changes" feature of the "%{crate}" crate.

%files       -n %{name}+i-implement-a-third-party-backend-and-opt-into-breaking-changes-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ipnet-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ipnet-devel %{_description}

This package contains library source intended for building other packages which
use the "ipnet" feature of the "%{crate}" crate.

%files       -n %{name}+ipnet-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ipnet-address-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ipnet-address-devel %{_description}

This package contains library source intended for building other packages which
use the "ipnet-address" feature of the "%{crate}" crate.

%files       -n %{name}+ipnet-address-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ipnetwork-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ipnetwork-devel %{_description}

This package contains library source intended for building other packages which
use the "ipnetwork" feature of the "%{crate}" crate.

%files       -n %{name}+ipnetwork-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+itoa-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+itoa-devel %{_description}

This package contains library source intended for building other packages which
use the "itoa" feature of the "%{crate}" crate.

%files       -n %{name}+itoa-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+large-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+large-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "large-tables" feature of the "%{crate}" crate.

%files       -n %{name}+large-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libc-devel %{_description}

This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.

%files       -n %{name}+libc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libsqlite3-sys-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libsqlite3-sys-devel %{_description}

This package contains library source intended for building other packages which
use the "libsqlite3-sys" feature of the "%{crate}" crate.

%files       -n %{name}+libsqlite3-sys-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+network-address-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+network-address-devel %{_description}

This package contains library source intended for building other packages which
use the "network-address" feature of the "%{crate}" crate.

%files       -n %{name}+network-address-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+nightly-error-messages-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+nightly-error-messages-devel %{_description}

This package contains library source intended for building other packages which
use the "nightly-error-messages" feature of the "%{crate}" crate.

%files       -n %{name}+nightly-error-messages-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+postgres-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+postgres-devel %{_description}

This package contains library source intended for building other packages which
use the "postgres" feature of the "%{crate}" crate.

%files       -n %{name}+postgres-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+postgres_backend-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+postgres_backend-devel %{_description}

This package contains library source intended for building other packages which
use the "postgres_backend" feature of the "%{crate}" crate.

%files       -n %{name}+postgres_backend-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+pq-sys-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pq-sys-devel %{_description}

This package contains library source intended for building other packages which
use the "pq-sys" feature of the "%{crate}" crate.

%files       -n %{name}+pq-sys-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+quickcheck-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+quickcheck-devel %{_description}

This package contains library source intended for building other packages which
use the "quickcheck" feature of the "%{crate}" crate.

%files       -n %{name}+quickcheck-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+r2d2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+r2d2-devel %{_description}

This package contains library source intended for building other packages which
use the "r2d2" feature of the "%{crate}" crate.

%files       -n %{name}+r2d2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+returning_clauses_for_sqlite_3_35-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+returning_clauses_for_sqlite_3_35-devel %{_description}

This package contains library source intended for building other packages which
use the "returning_clauses_for_sqlite_3_35" feature of the "%{crate}" crate.

%files       -n %{name}+returning_clauses_for_sqlite_3_35-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde_json-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde_json-devel %{_description}

This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.

%files       -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+sqlite-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+sqlite-devel %{_description}

This package contains library source intended for building other packages which
use the "sqlite" feature of the "%{crate}" crate.

%files       -n %{name}+sqlite-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+time-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+time-devel %{_description}

This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.

%files       -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+uuid-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+uuid-devel %{_description}

This package contains library source intended for building other packages which
use the "uuid" feature of the "%{crate}" crate.

%files       -n %{name}+uuid-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+with-deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+with-deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "with-deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+with-deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+without-deprecated-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+without-deprecated-devel %{_description}

This package contains library source intended for building other packages which
use the "without-deprecated" feature of the "%{crate}" crate.

%files       -n %{name}+without-deprecated-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires -f sqlite

%build
%cargo_build -f sqlite

%install
%cargo_install -f sqlite

%if %{with check}
%check
%cargo_test -f sqlite
%endif

%changelog
%autochangelog