Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check

%global crate diskonaut

Name:           rust-diskonaut
Version:        0.11.0
Release:        %autorelease
Summary:        Terminal disk space visual navigator

License:        MIT
URL:            https://crates.io/crates/diskonaut
Source:         %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch:          diskonaut-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * bump jwalk dependency from 0.5 to 0.6:
#   https://github.com/imsnif/diskonaut/pull/83
# * bump insta dev-dependency from 0.16 to 1.7
Patch:          diskonaut-fix-metadata.diff

BuildRequires:  rust-packaging >= 23

%global _description %{expand:
Terminal disk space visual navigator.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# 0BSD OR MIT OR Apache-2.0
# Apache-2.0 OR MIT
# BSD-3-Clause
# MIT
# MIT OR Apache-2.0
# MIT OR Zlib OR Apache-2.0
# Unlicense OR MIT
License:        MIT AND BSD-3-Clause AND (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR MIT) AND (MIT OR Zlib OR Apache-2.0) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc CHANGELOG.md
%doc CODE_OF_CONDUCT.md
%doc CONTRIBUTING.md
%doc README.md
%{_bindir}/diskonaut

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build
%cargo_license_summary
%{cargo_license} > LICENSE.dependencies

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog