Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate fasteval

Name:           rust-fasteval
Version:        0.2.4
Release:        %autorelease
Summary:        Fast evaluation of algebraic expressions

License:        MIT
URL:            https://crates.io/crates/fasteval
Source:         %{crates_source}

# https://github.com/likebike/fasteval/pull/17
Patch:          0001-Rust-can-parse-Very-Long-nine-tails-since-1.55.0.patch
# https://github.com/likebike/fasteval/pull/18
Patch:          0002-Docs-avoid-doc-test-error-when-unsafe-vars-are-not-e.patch
Patch:          0003-Docs-markdown-syntax-fix.patch
Patch:          0001-tests-update-to-scientic-notation.patch

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Fast evaluation of algebraic expressions.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+alpha-keywords-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+alpha-keywords-devel %{_description}

This package contains library source intended for building other packages which
use the "alpha-keywords" feature of the "%{crate}" crate.

%files       -n %{name}+alpha-keywords-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+nightly-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+nightly-devel %{_description}

This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.

%files       -n %{name}+nightly-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unsafe-vars-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unsafe-vars-devel %{_description}

This package contains library source intended for building other packages which
use the "unsafe-vars" feature of the "%{crate}" crate.

%files       -n %{name}+unsafe-vars-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog