Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate number_prefix

Name:           rust-number_prefix
Version:        0.4.0
Release:        %autorelease
Summary:        Library for numeric prefixes (kilo, giga, kibi)

License:        MIT
URL:            https://crates.io/crates/number_prefix
Source0:        %{crates_source}
Source1:        https://github.com/ogham/rust-number-prefix/raw/v%{version}/LICENCE
# Manually created patch for downstream crate metadata changes
# * do not exclude license text from installed files
#   https://github.com/ogham/rust-number-prefix/pull/8
Patch:          number_prefix-fix-metadata.diff

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Library for numeric prefixes (kilo, giga, kibi).}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENCE
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} .

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog