Blob Blame History Raw
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}

%global crate open

Name:           rust-open
Version:        3.0.3
Release:        %autorelease
Summary:        Open a path or URL using the program configured on the system

License:        MIT
URL:            https://crates.io/crates/open
Source:         %{crates_source}
# Automatically generated patch to strip foreign dependencies
Patch:          open-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop useless /usr/bin/open binary
Patch:          open-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Open a path or URL using the program configured on the system.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       /usr/bin/xdg-open

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/changelog.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog