Blob Blame History Raw
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate openssl-sys

Name:           rust-openssl-sys
Version:        0.9.102
Release:        %autorelease
Summary:        FFI bindings to OpenSSL

License:        MIT
URL:            https://crates.io/crates/openssl-sys
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * relax bindgen dependency from ^0.65 to >=0.64
# * drop feature and dependencies for unstable BoringSSL support
# * drop feature and dependencies for building against vendored OpenSSL sources
# * drop Windows-specific vcpkg build-dependency:
#   https://github.com/sfackler/rust-openssl/issues/2031
Patch:          openssl-sys-fix-metadata.diff
Patch:          0001-drop-Windows-specific-references-to-vcpkg.patch

BuildRequires:  cargo-rpm-macros >= 24
BuildRequires:  pkgconfig(openssl) >= 1.0.1

%global _description %{expand:
FFI bindings to OpenSSL.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(openssl) >= 1.0.1

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bindgen-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bindgen-devel %{_description}

This package contains library source intended for building other packages which
use the "bindgen" feature of the "%{crate}" crate.

%files       -n %{name}+bindgen-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog