Blob Blame History Raw
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}

%global crate pathfinder_geometry

Name:           rust-pathfinder_geometry
Version:        0.5.1
Release:        %autorelease
Summary:        Basic SIMD-accelerated geometry/linear algebra

# Upstream license specification: MIT/Apache-2.0
License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/pathfinder_geometry
Source0:        %{crates_source}
# https://github.com/servo/pathfinder/issues/443
Source1:        https://github.com/servo/pathfinder/raw/pathfinder_simd-v0.5.1/LICENSE-APACHE
Source2:        https://github.com/servo/pathfinder/raw/pathfinder_simd-v0.5.1/LICENSE-MIT

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Basic SIMD-accelerated geometry/linear algebra.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} %{SOURCE2} .

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog