Blob Blame History Raw
# Generated by rust2rpm 26
# * missing dev-dependencies: gl ^0.14
%bcond_with check
%global debug_package %{nil}

%global crate xcb

Name:           rust-xcb
Version:        1.4.0
Release:        %autorelease
Summary:        Rust safe bindings for XCB

License:        MIT
URL:            https://crates.io/crates/xcb
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24
BuildRequires:  libxcb-devel

%global _description %{expand:
Rust safe bindings for XCB.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       libxcb-devel

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/EXCEPTION_LIST.txt
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/TODO_v1.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+as-raw-xcb-connection-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+as-raw-xcb-connection-devel %{_description}

This package contains library source intended for building other packages which
use the "as-raw-xcb-connection" feature of the "%{crate}" crate.

%files       -n %{name}+as-raw-xcb-connection-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+composite-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+composite-devel %{_description}

This package contains library source intended for building other packages which
use the "composite" feature of the "%{crate}" crate.

%files       -n %{name}+composite-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+damage-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+damage-devel %{_description}

This package contains library source intended for building other packages which
use the "damage" feature of the "%{crate}" crate.

%files       -n %{name}+damage-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+debug_atom_names-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+debug_atom_names-devel %{_description}

This package contains library source intended for building other packages which
use the "debug_atom_names" feature of the "%{crate}" crate.

%files       -n %{name}+debug_atom_names-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+dpms-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dpms-devel %{_description}

This package contains library source intended for building other packages which
use the "dpms" feature of the "%{crate}" crate.

%files       -n %{name}+dpms-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+dri2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dri2-devel %{_description}

This package contains library source intended for building other packages which
use the "dri2" feature of the "%{crate}" crate.

%files       -n %{name}+dri2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+dri3-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dri3-devel %{_description}

This package contains library source intended for building other packages which
use the "dri3" feature of the "%{crate}" crate.

%files       -n %{name}+dri3-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ge-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ge-devel %{_description}

This package contains library source intended for building other packages which
use the "ge" feature of the "%{crate}" crate.

%files       -n %{name}+ge-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+glx-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+glx-devel %{_description}

This package contains library source intended for building other packages which
use the "glx" feature of the "%{crate}" crate.

%files       -n %{name}+glx-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libxcb_v1_14-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libxcb_v1_14-devel %{_description}

This package contains library source intended for building other packages which
use the "libxcb_v1_14" feature of the "%{crate}" crate.

%files       -n %{name}+libxcb_v1_14-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+present-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+present-devel %{_description}

This package contains library source intended for building other packages which
use the "present" feature of the "%{crate}" crate.

%files       -n %{name}+present-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+randr-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+randr-devel %{_description}

This package contains library source intended for building other packages which
use the "randr" feature of the "%{crate}" crate.

%files       -n %{name}+randr-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+record-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+record-devel %{_description}

This package contains library source intended for building other packages which
use the "record" feature of the "%{crate}" crate.

%files       -n %{name}+record-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+render-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+render-devel %{_description}

This package contains library source intended for building other packages which
use the "render" feature of the "%{crate}" crate.

%files       -n %{name}+render-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+res-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+res-devel %{_description}

This package contains library source intended for building other packages which
use the "res" feature of the "%{crate}" crate.

%files       -n %{name}+res-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+screensaver-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+screensaver-devel %{_description}

This package contains library source intended for building other packages which
use the "screensaver" feature of the "%{crate}" crate.

%files       -n %{name}+screensaver-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+shape-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+shape-devel %{_description}

This package contains library source intended for building other packages which
use the "shape" feature of the "%{crate}" crate.

%files       -n %{name}+shape-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+shm-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+shm-devel %{_description}

This package contains library source intended for building other packages which
use the "shm" feature of the "%{crate}" crate.

%files       -n %{name}+shm-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+sync-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+sync-devel %{_description}

This package contains library source intended for building other packages which
use the "sync" feature of the "%{crate}" crate.

%files       -n %{name}+sync-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+x11-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+x11-devel %{_description}

This package contains library source intended for building other packages which
use the "x11" feature of the "%{crate}" crate.

%files       -n %{name}+x11-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xevie-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xevie-devel %{_description}

This package contains library source intended for building other packages which
use the "xevie" feature of the "%{crate}" crate.

%files       -n %{name}+xevie-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xf86dri-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xf86dri-devel %{_description}

This package contains library source intended for building other packages which
use the "xf86dri" feature of the "%{crate}" crate.

%files       -n %{name}+xf86dri-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xf86vidmode-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xf86vidmode-devel %{_description}

This package contains library source intended for building other packages which
use the "xf86vidmode" feature of the "%{crate}" crate.

%files       -n %{name}+xf86vidmode-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xfixes-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xfixes-devel %{_description}

This package contains library source intended for building other packages which
use the "xfixes" feature of the "%{crate}" crate.

%files       -n %{name}+xfixes-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xinerama-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xinerama-devel %{_description}

This package contains library source intended for building other packages which
use the "xinerama" feature of the "%{crate}" crate.

%files       -n %{name}+xinerama-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xinput-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xinput-devel %{_description}

This package contains library source intended for building other packages which
use the "xinput" feature of the "%{crate}" crate.

%files       -n %{name}+xinput-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xkb-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xkb-devel %{_description}

This package contains library source intended for building other packages which
use the "xkb" feature of the "%{crate}" crate.

%files       -n %{name}+xkb-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xlib_xcb-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xlib_xcb-devel %{_description}

This package contains library source intended for building other packages which
use the "xlib_xcb" feature of the "%{crate}" crate.

%files       -n %{name}+xlib_xcb-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xprint-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xprint-devel %{_description}

This package contains library source intended for building other packages which
use the "xprint" feature of the "%{crate}" crate.

%files       -n %{name}+xprint-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xselinux-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xselinux-devel %{_description}

This package contains library source intended for building other packages which
use the "xselinux" feature of the "%{crate}" crate.

%files       -n %{name}+xselinux-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xtest-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xtest-devel %{_description}

This package contains library source intended for building other packages which
use the "xtest" feature of the "%{crate}" crate.

%files       -n %{name}+xtest-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xv-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xv-devel %{_description}

This package contains library source intended for building other packages which
use the "xv" feature of the "%{crate}" crate.

%files       -n %{name}+xv-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xvmc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xvmc-devel %{_description}

This package contains library source intended for building other packages which
use the "xvmc" feature of the "%{crate}" crate.

%files       -n %{name}+xvmc-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog