8630fb scl-utils is not compatible with Lmod, fix the dependency (#1296383)

Authored and Committed by pmatilai 2 years ago
    scl-utils is not compatible with Lmod, fix the dependency (#1296383)
    
    scl-utils uses %{_bindir}/modulecmd which is not the alleged official
    interface, but since "module" command is implemented as a shell
    function/alias, calling it via exec() from C is a bit problematic.
    Maybe there are ways around but the current implementation depends
    on %{_bindir}/modulecmd being there, and thus it's not compatible
    with Lmod.
    
    This effectively reverts 969a3eb2f56679f81d60fcaad1b4a098dd6d417b but
    by depending on %{_bindir}/modulecmd instead of the pacakge name,
    makes the point clearer I hope.
    
        
file modified
+5 -2