Blob Blame History Raw
%bcond_without	system_nspr
%bcond_without	system_nss
%bcond_without	system_libvpx

%define homepage http://start.fedoraproject.org/
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%define cairo_version 0.5

%global minimum_build_nspr_version 4.10.3
%global minimum_build_nss_version 3.17.2
%global minimum_build_vpx_version 1.3.0

%define build_langpacks 1

%define _unpackaged_files_terminate_build 0
%define builddir %{_builddir}/%{name}-%{version}
%define mozdir %{_libdir}/seamonkey
%define sources_subdir comm-release

%define seamonkey_app_id       \{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a\}


Name:           seamonkey
Summary:        Web browser, e-mail, news, IRC client, HTML editor
Version:        2.31
Release:        1%{?dist}
URL:            http://www.mozilla.org/projects/seamonkey/
License:        MPLv2.0
Group:          Applications/Internet

Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}%{?prerelease_tag}.source.tar.bz2

#  Generate it by moz-grab-langpacks script, which can be obtained from
#  http://fedorapeople.org/cgit/caillon/public_git/gecko-maint.git/
#  and probably perform "sed -i 's/pyfedpkg/pyrpkg/g' moz-grab-langpacks"
#
#   Run script as  ./moz-grab-langpacks --app seamonkey %{version}
#
Source1:        seamonkey-langpacks-%{version}-20141215.tar.xz

Source3:        seamonkey.sh.in
Source4:        seamonkey.desktop
Source7:        seamonkey-make-package.pl
Source10:       seamonkey-mozconfig
Source12:       seamonkey-mail.desktop
Source13:       seamonkey-mail.svg
Source17:       mozilla-psm-exclude-list
Source18:       mozilla-xpcom-exclude-list
Source20:       seamonkey-fedora-default-prefs.js-2.31
Source100:      seamonkey-find-requires.sh

Patch2:         xulrunner-24.0-jemalloc-ppc.patch
Patch3:         xulrunner-27.0-build-arm.patch
Patch4:         firefox-33-rhbz-966424.patch
Patch5:         firefox-34-mozilla-858919.patch
Patch9:         firefox-34-baseline-disable.patch
Patch10:        firefox-33-build-prbool.patch
Patch15:        seamonkey-2.29-enable-addons.patch
Patch22:        seamonkey-2.31-installdir.patch
Patch23:        seamonkey-2.25-elfhack.patch

Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%if %{with system_nspr}
BuildRequires:  nspr-devel >= %{minimum_build_nspr_version}
%endif
%if %{with system_nss}
BuildRequires:  nss-devel >= %{minimum_build_nss_version}
BuildRequires:  nss-static >= %{minimum_build_nss_version}
%endif
BuildRequires:  cairo-devel >= %{cairo_version}
BuildRequires:  libpng-devel
BuildRequires:  libjpeg-turbo-devel
BuildRequires:  zlib-devel
BuildRequires:  zip
BuildRequires:  libIDL-devel
BuildRequires:  desktop-file-utils
BuildRequires:  gtk2-devel
BuildRequires:  dbus-glib-devel
BuildRequires:  gnome-vfs2-devel
BuildRequires:  libgnome-devel
BuildRequires:  libgnomeui-devel
BuildRequires:  krb5-devel
BuildRequires:  pango-devel
BuildRequires:  freetype-devel >= 2.1.9
BuildRequires:  glib2-devel
BuildRequires:  libXt-devel
BuildRequires:  libXrender-devel
BuildRequires:  fileutils
BuildRequires:  perl
BuildRequires:  alsa-lib-devel
BuildRequires:  hunspell-devel
BuildRequires:  system-bookmarks
BuildRequires:  libnotify-devel
%if %{with system_libvpx}
BuildRequires:  libvpx-devel >= %{minimum_build_vpx_version}
%else
BuildRequires:  yasm >= 1.1
%endif
BuildRequires:  mesa-libGL-devel
Buildrequires:  pulseaudio-libs-devel
BuildRequires:  python >= 2.7

Requires:       system-bookmarks
Requires:       mozilla-filesystem
Requires:       hicolor-icon-theme
%if %{with system_nspr}
Requires:       nspr >= %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo %{minimum_build_nspr_version})
%endif
%if %{with system_nss}
Requires:       nss >= %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo %{minimum_build_nss_version})
%endif

Obsoletes: seamonkey-chat
Obsoletes: seamonkey-devel
Obsoletes: seamonkey-dom-inspector
Obsoletes: seamonkey-js-debugger
Obsoletes: seamonkey-mail

# ppc64:   http://bugzilla.redhat.com/bugzilla/866589
# armv7hl: http://bugzilla.redhat.com/bugzilla/1035485
ExcludeArch: ppc64, armv7hl


AutoProv: 0
%define _use_internal_dependency_generator 0
%define __find_requires %{SOURCE100}


%description
SeaMonkey is an all-in-one Internet application suite. It includes 
a browser, mail/news client, IRC client, JavaScript debugger, and 
a tool to inspect the DOM for web pages. It is derived from the 
application formerly known as Mozilla Application Suite.
 

%prep

%setup -q -c
cd %{sources_subdir}

pushd mozilla
%patch2 -p2 -b .jemalloc-ppc
%patch3 -p2 -b .build-arm
%patch4 -p2 -b .966424
%patch5 -p1 -b .858919
%ifarch %{ix86}
%patch9 -p2 -b .baseline
%endif
%patch10 -p1 -b .prbool
popd

%patch15 -p2 -b .addons

%patch22 -p2 -b .installdir
%patch23 -p2 -b .elfhack

# fix obsoleted modifier in inspector
sed -i -e 's/ *xpcnativewrappers=no//' mozilla/extensions/inspector/jar.mn

%{__rm} -f .mozconfig
%{__cp} %{SOURCE10} .mozconfig

%ifarch %{arm}
echo "ac_add_options --disable-elf-hack" >> .mozconfig
%endif

echo "ac_add_options --with%{!?with_system_nspr:out}-system-nspr" >> .mozconfig
echo "ac_add_options --with%{!?with_system_nss:out}-system-nss" >> .mozconfig
echo "ac_add_options --with%{!?with_system_libvpx:out}-system-libvpx" >> .mozconfig

%ifnarch %{ix86} x86_64
echo "ac_add_options --disable-webrtc" >> .mozconfig
%endif

#  enabled by default since 2.21
echo "ac_add_options --disable-gstreamer" >> .mozconfig


%build
cd %{sources_subdir}

# Mozilla builds with -Wall with exception of a few warnings which show up
# everywhere in the code; so, don't override that.
#
# Disable C++ exceptions since Mozilla code is not exception-safe
#
MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | \
                     %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
#  needed for -Werror=format-security
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -Wformat"

export CFLAGS=$MOZ_OPT_FLAGS
export CXXFLAGS=$MOZ_OPT_FLAGS

# To avoid link time crashes with not enough memory
# (approximately <= 4Gb)
%if %(awk '/^MemTotal:/ { print $2 }' /proc/meminfo) <= 4200000
MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
export LDFLAGS=$MOZ_LINK_FLAGS
%endif

export PREFIX='%{_prefix}'
export LIBDIR='%{_libdir}'

MOZ_SMP_FLAGS=-j1
%ifnarch ppc ppc64 s390 s390x
MOZ_SMP_FLAGS=%{?_smp_mflags}
%endif

#  a kludge since 2.26 ...
ln -s ../objdir mozilla/objdir

make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"


%install
%{__rm} -rf $RPM_BUILD_ROOT

cd %{sources_subdir}

DESTDIR=$RPM_BUILD_ROOT make -C objdir install

# create a list of all of the different package and the files that
# will hold them

%{__rm} -f %{builddir}/seamonkey.list

echo %defattr\(-,root,root\) > %{builddir}/seamonkey.list

# we don't want to ship mozilla's default sidebar components
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/bugzilla.gif
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/bugzilla.src
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/dmoz.gif
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/dmoz.src
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/lxrmozilla.gif
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/lxrmozilla.src
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/mozilla.gif
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/searchplugins/mozilla.src

# build all of the default browser components 
# base Seamonkey package (seamonkey.list) 
%{SOURCE7} --package xpcom --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir} \
    %{?with_system_nspr:--exclude-file=%{SOURCE18}}

%{SOURCE7} --package browser --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir}

%{SOURCE7} --package spellcheck --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir}

%{SOURCE7} --package psm --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir} \
    %{?with_system_nss:--exclude-file=%{SOURCE17}}

%{SOURCE7} --package mail --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir}

%{SOURCE7} --package chatzilla --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir}

%{SOURCE7} --package venkman --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir}

%{SOURCE7} --package inspector --output-file %{builddir}/seamonkey.list \
    --package-file objdir/suite/installer/package-manifest \
    --install-dir $RPM_BUILD_ROOT/%{mozdir} \
    --install-root %{mozdir}

echo > ../%{name}.lang

%if %{build_langpacks}
# Install langpacks 
%{__mkdir_p} $RPM_BUILD_ROOT/%{mozdir}/extensions
%{__tar} xf %{SOURCE1}

for langpack in `ls seamonkey-langpacks/*.xpi`; do
  #  seamonkey-langpacks/seamonkey-VERSION.LANG.langpack.xpi
  language=${langpack%.langpack.xpi}
  #  seamonkey-langpacks/seamonkey-VERSION.LANG
  language=${language##*.}
  #  LANG
  extensiondir=$RPM_BUILD_ROOT/%{mozdir}/extensions/langpack-$language@seamonkey.mozilla.org
  %{__mkdir_p} $extensiondir
  unzip $langpack -d $extensiondir
  find $extensiondir -type f | xargs chmod 644
  find $extensiondir -name ".mkdir.done" | xargs rm -f

  sed -i -e "s|browser.startup.homepage.*$|browser.startup.homepage = %{homepage}|g" \
         $extensiondir/chrome/$language/locale/$language/navigator-region/region.properties

  jarfile=$extensiondir/chrome/$language.jar
  pushd $extensiondir/chrome/$language
  zip -r -D $jarfile locale
  popd
  %{__rm} -rf $extensiondir/chrome/$language  #  now in jarfile

  mv -f $extensiondir/chrome/$language.manifest $extensiondir/chrome.manifest
  #  fix manifest to point to jar
  sed -i -e "s,$language/locale,jar:chrome/$language.jar!/locale," \
         $extensiondir/chrome.manifest

  language=`echo $language | sed -e 's/-/_/g'`
  extensiondir=`echo $extensiondir | sed -e "s,^$RPM_BUILD_ROOT,,"`
  echo "%%lang($language) $extensiondir" >> ../%{name}.lang
done

%{__rm} -rf seamonkey-langpacks
%endif # build_langpacks

# install desktop files in correct directory
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/applications/
desktop-file-install --vendor mozilla \
    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
    --add-category X-Fedora \
    --add-category Application \
    --add-category Network \
    %{SOURCE4}
desktop-file-install --vendor mozilla \
    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
    --add-category X-Fedora \
    --add-category Application \
    --add-category Network \
    %{SOURCE12}

# install icons
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps

# seamonkey icons
install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/main-window16.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/seamonkey.png

install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/main-window.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/seamonkey.png

install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/main-window48.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/seamonkey.png

install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/seamonkey.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/seamonkey.png

# seamonkey mail icons
install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/messengerWindow16.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/seamonkey-mail.png

install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/messengerWindow.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/seamonkey-mail.png

install -p -m 644 $RPM_BUILD_ROOT%{mozdir}/chrome/icons/default/messengerWindow48.png \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/seamonkey-mail.png

install -p -m 644 %{SOURCE13} \
    $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/seamonkey-mail.svg

if [ ! -d $RPM_BUILD_ROOT/%{mozdir}/plugins/ ]; then
  mkdir -m 755 $RPM_BUILD_ROOT/%{mozdir}/plugins
fi

# install our seamonkey.sh file
rm -rf $RPM_BUILD_ROOT/usr/bin/seamonkey
cat %{SOURCE3} | sed -e 's/-MOZILLA_VERSION//g' \
                     -e 's,LIBDIR,%{_libdir},g' > \
  $RPM_BUILD_ROOT/usr/bin/seamonkey

chmod 755 $RPM_BUILD_ROOT/usr/bin/seamonkey

# set up our default preferences
%{__cat} %{SOURCE20} | %{__sed} -e 's,SEAMONKEY_RPM_VR,%{version}-%{release},g' > \
        $RPM_BUILD_ROOT/fc-default-prefs
%{__cp} $RPM_BUILD_ROOT/fc-default-prefs $RPM_BUILD_ROOT/%{mozdir}/defaults/pref/all-fedora.js
%{__rm} $RPM_BUILD_ROOT/fc-default-prefs

# set up our default bookmarks
%{__rm} -f $RPM_BUILD_ROOT/%{mozdir}/defaults/profile/bookmarks.html
ln -s %{default_bookmarks_file} $RPM_BUILD_ROOT/%{mozdir}/defaults/profile/bookmarks.html

# System extensions
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{seamonkey_app_id}
%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{seamonkey_app_id}


%clean
%{__rm} -rf $RPM_BUILD_ROOT


%post
update-desktop-database -q &> /dev/null
/bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :


%postun
update-desktop-database -q &> /dev/null
if [ $1 -eq 0 ] ; then
    /bin/touch --no-create %{_datadir}/icons/hicolor &>/dev/null
    /usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi


%posttrans
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :


%files -f seamonkey.list
%defattr(-,root,root)
%{_bindir}/seamonkey
%{_datadir}/icons/hicolor/16x16/apps/seamonkey.png
%{_datadir}/icons/hicolor/16x16/apps/seamonkey-mail.png
%{_datadir}/icons/hicolor/32x32/apps/seamonkey.png
%{_datadir}/icons/hicolor/32x32/apps/seamonkey-mail.png
%{_datadir}/icons/hicolor/48x48/apps/seamonkey.png
%{_datadir}/icons/hicolor/48x48/apps/seamonkey-mail.png
%{_datadir}/icons/hicolor/128x128/apps/seamonkey.png
%{_datadir}/icons/hicolor/scalable/apps/seamonkey-mail.svg

# search engines
%{mozdir}/searchplugins/*.xml

# dictionaries
%{mozdir}/dictionaries/*

# Profile?
%{mozdir}/defaults/profile/*

# some rest
%{mozdir}/omni.ja
%{mozdir}/chrome.manifest
%{mozdir}/components/*.manifest
#%{mozdir}/components/*.xpt
%{mozdir}/components/*.so
%{mozdir}/defaults/messenger/mailViews.dat
%dir %{mozdir}/extensions
%{mozdir}/extensions/*

%dir %{mozdir}/distribution
%dir %{mozdir}/distribution/extensions

#%doc %{_mandir}/man1/seamonkey.1.gz

%dir %{mozdir}
%dir %{mozdir}/defaults/pref
%dir %{mozdir}/defaults/profile
%dir %{mozdir}/defaults/messenger
%dir %{mozdir}/defaults

%dir %{mozdir}/chrome/icons/default
%dir %{mozdir}/chrome/icons
%dir %{mozdir}/chrome


%dir %{mozdir}/components
%dir %{mozdir}/searchplugins

%dir %{mozdir}/isp
%dir %{mozdir}/dictionaries

%dir %{mozdir}/plugins

%{mozdir}/defaults/pref/all-fedora.js

%{_datadir}/applications/mozilla-%{name}.desktop
%{_datadir}/applications/mozilla-%{name}-mail.desktop

%dir %{_datadir}/mozilla/extensions/%{seamonkey_app_id}
%dir %{_libdir}/mozilla/extensions/%{seamonkey_app_id}

%if %{without system_nss}
%{mozdir}/*.chk
%endif

%ghost %{mozdir}/removed-files


%changelog
* Mon Dec 15 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.31-1
- update to 2.31
- apply some patches from firefox-34 package

* Sat Oct 25 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.30-1
- update to 2.30
- apply some patches from firefox-33 package

* Fri Sep 26 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.29.1-1
- update to 2.29.1

* Sat Sep 20 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.29-1
- update to 2.29
- apply some patches from firefox-32 package

* Wed Aug 20 2014 Kevin Fenzi <kevin@scrye.com> - 2.26.1-3
- Rebuild for rpm bug 1131892

* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.26.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

* Tue Jun 24 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.26.1-1
- update to 2.26.1

* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.26-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Fri May  9 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.26-2
- rebuild with new find-requires script

* Fri May  9 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.26-1
- update to 2.26

* Mon Mar 24 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.25-1
- update to 2.25

* Mon Feb 10 2014 Dmitry Butskoy <Dmitry@Butskoy.name> 2.24-1
- update to 2.24

* Wed Dec 18 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.23-1
- update to 2.23

* Wed Nov 27 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.22.1-1
- update to 2.22.1
- don't build for armv7hl (seems not enough memory on the build system, #1035485)

* Sat Nov  2 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.22-1
- update to 2.22

* Thu Sep 19 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.21-1
- update to 2.21

* Thu Aug  8 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.20-1
- update to 2.20

* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.19-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Mon Jul 15 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.19-2
- implement separate switches for system/native nspr, nss and libvpx

* Mon Jul  8 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.19-1
- update to 2.19

* Mon Apr 15 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.17.1-1
- update to 2.17.1

* Wed Apr  3 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.17-1
- update to 2.17
- explicitly require libjpeg-turbo (for JCS_EXTENSIONS)

* Tue Mar 26 2013 Peter Robinson <pbrobinson@fedoraproject.org> 2.16.2-2
- Only build WebRTC on x86 to fix FTBFS on other arches

* Fri Mar 15 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.16.2-1
- update to 2.16.2
- fix desktop files (#887297)

* Tue Mar 12 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.16.1-1
- update to 2.16.1

* Fri Feb 22 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.16-1
- update to 2.16
- fix build langpacks

* Tue Feb  5 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.15.2-1
- update to 2.15.2

* Sun Jan 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.15.1-2
- silence scriptlet output

* Tue Jan 22 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.15.1-1
- update to 2.15.1

* Fri Jan 11 2013 Dmitry Butskoy <Dmitry@Butskoy.name> 2.15-1
- update to 2.15
- don't try to change global user settings for default browser/mail etc.
- add fix for #304121 (derived from Xulrunner)

* Mon Dec  3 2012 Dmitry Butskoy <Dmitry@Butskoy.name> 2.14.1-1
- update to 2.14.1

* Thu Nov 22 2012 Dmitry Butskoy <Dmitry@Butskoy.name> 2.14-1
- update to 2.14
- fix elfhack compile

* Wed Oct 31 2012 Dmitry Butskoy <Dmitry@Butskoy.name> 2.13.2-2
- exclude ppc64 arch (hoping it is temporary, #866589)
- fix startup warnings (error console) for omni and inspector
- fix build langpacks
- change License to MPLv2.0
- add seamonkey-related directories in mozilla-filesystem (#865054)
- use proper MOZ_SMP_FLAGS
- add patch for jemalloc for powerpc arches (#852698)
- add patch to avoid decommit memory on powerpc arches (#852698)
- some cleanups in spec file
- drop version from install directories (follow the current firefox
  and thunderbird way)

* Fri Oct 26 2012 Martin Stransky <stransky@redhat.com> 2.13.2-1
- Update to 2.13.2

* Tue Oct 16 2012 Martin Stransky <stransky@redhat.com> 2.13.1-1
- Update to 2.13.1

* Tue Oct 9 2012 Martin Stransky <stransky@redhat.com> 2.13-1
- Update to 2.13

* Tue Aug 28 2012 Martin Stransky <stransky@redhat.com> 2.12.1-1
- Update to 2.12.1

* Tue Aug 28 2012 Martin Stransky <stransky@redhat.com> 2.12-1
- Update to 2.12

* Fri Jul 27 2012 Martin Stransky <stransky@redhat.com> 2.11-1
- Update to 2.11

* Thu Jun 21 2012 Martin Stransky <stransky@redhat.com> 2.10.1-1
- Update to 2.10.1

* Thu Jun 7 2012 Allen Hewes <allen@decisiv.net> 2.10-1
- Update to 2.10
- change sed string for version number to support 2 digits
- remove specific .so's from installer manifest
- fix the cache path for header.py and associated files when building
  in srcdir (vs using seperate objdir)

* Mon May 7 2012 Martin Stransky <stransky@redhat.com> 2.9.1-4
- Fixed #717242 - does not adhere to Static Library Packaging Guidelines

* Thu May 3 2012 Martin Stransky <stransky@redhat.com> 2.9.1-3
- Fixed #747411 - seamonkey needs better icons (by Edward Sheldrake)

* Thu May 3 2012 Martin Stransky <stransky@redhat.com> 2.9.1-2
- Fixed directories (#566901)

* Wed May 2 2012 Martin Stransky <stransky@redhat.com> 2.9.1-1
- Update to 2.9.1

* Fri Apr 27 2012 Martin Stransky <stransky@redhat.com> 2.9-1
- Update to 2.9

* Wed Apr  4 2012 Peter Robinson <pbrobinson@fedoraproject.org> 2.8-3
- Add ARM configuration options

* Fri Mar 16 2012 Martin Stransky <stransky@redhat.com> 2.8-2
- gcc 4.7 build fixes

* Thu Mar 15 2012 Martin Stransky <stransky@redhat.com> 2.8-1
- Update to 2.8

* Fri Feb 24 2012 Martin Stransky <stransky@redhat.com> 2.7.1-2
- Added fix for mozbz#727401 - libpng crash

* Tue Feb 14 2012 Martin Stransky <stransky@redhat.com> 2.7.1-1
- Update to 2.7.1

* Mon Feb  6 2012 Martin Stransky <stransky@redhat.com> 2.7-2
- gcc 4.7 build fixes

* Fri Feb  3 2012 Martin Stransky <stransky@redhat.com> 2.7-1
- Update to 2.7

* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

* Wed Dec 14 2011 Martin Stransky <stransky@redhat.com> 2.5-2
- Fixed langpacks

* Thu Dec  8 2011 Martin Stransky <stransky@redhat.com> 2.5-1
- Update to 2.5

* Fri Oct 14 2011 Dan Horák <dan[at]danny.cz> - 2.4.1-3
- fix build on secondary arches

* Tue Oct 11 2011 Kai Engert <kaie@redhat.com> - 2.4.1-2
- Update to 2.4.1

* Tue Sep 06 2011 Kai Engert <kaie@redhat.com> - 2.3.3-2
- Update to 2.3.3
 
* Sun Aug 21 2011 Kai Engert <kaie@redhat.com> - 2.3-2
- Update to 2.3
 
* Wed May 25 2011 Caolán McNamara <caolanm@redhat.com> - 2.0.14-2
- rebuild for new hunspell

* Fri Apr 29 2011 Jan Horak <jhorak@redhat.com> - 2.0.14-1
- Update to 2.0.14

* Sat Apr  9 2011 Christopher Aillon <caillon@redhat.com> 2.0.13-1
- Update to 2.0.13

* Mon Mar  7 2011 Martin Stransky <stransky@redhat.com> 2.0.12-1
- Update to 2.0.12

* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.11-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

* Tue Jan 04 2011 Adel Gadllah <adel.gadllah@gmail.com> 2.0.11-3
- BR dbus-glib-devel

* Tue Jan 04 2011 Adel Gadllah <adel.gadllah@gmail.com> 2.0.11-2
- disabled system cairo, breaks animated gifs (rhbz#628331)

* Mon Dec 13 2010 Martin Stransky <stransky@redhat.com> 2.0.11-1
- Update to 2.0.11

* Mon Nov 1 2010 Martin Stransky <stransky@redhat.com> 2.0.10-1
- Update to 2.0.10

* Thu Oct 21 2010 Martin Stransky <stransky@redhat.com> 2.0.9-1
- Update to 2.0.9

* Wed Oct 13 2010 Martin Stransky <stransky@redhat.com> 2.0.8-2
- Added fix for mozbz#522635

* Wed Sep 22 2010 Martin Stransky <stransky@redhat.com> 2.0.8-1
- Update to 2.0.8

* Tue Jul 20 2010 Martin Stransky <stransky@redhat.com> 2.0.6-1
- Update to 2.0.6

* Wed Jun 23 2010 Martin Stransky <stransky@redhat.com> 2.0.5-1
- Update to 2.0.5

* Thu Apr  1 2010 Martin Stransky <stransky@redhat.com> 2.0.4-1
- Update to 2.0.4

* Wed Feb 17 2010 Martin Stransky <stransky@redhat.com> 2.0.3-1
- Update to 2.0.3

* Thu Dec 17 2009 Jan Horak <jhorak@redhat.com> - 2.0.1-1
- Update to 2.0.1

* Tue Oct 27 2009 Martin Stransky <stransky@redhat.com> 2.0-7
- Update to 2.0

* Wed Oct 21 2009 Martin Stransky <stransky@redhat.com> 2.0-6
- Fixed launcher script

* Mon Oct 19 2009 Martin Stransky <stransky@redhat.com> 2.0-5
- Update to 2.0 RC2

* Tue Oct 13 2009 Martin Stransky <stransky@redhat.com> 2.0-4
- Update to 2.0 RC1

* Wed Sep 23 2009 Martin Stransky <stransky@redhat.com> 2.0-3.beta2
- Update to 2.0 beta 2

* Thu Aug 6 2009 Martin Stransky <stransky@redhat.com> 2.0-2.beta1
- Added fix for #437596

* Wed Jul 22 2009 Martin Stransky <stransky@redhat.com> 2.0-1.beta1
- Update to 2.0 beta 1

* Fri Jul 10 2009 Martin Stransky <stransky@redhat.com> 1.1.17-1
- Update to 1.1.17

* Thu Jun 18 2009 Kai Engert <kaie@redhat.com> 1.1.16-3
- fix categories in desktop files

* Thu May  7 2009 Kai Engert <kaie@redhat.com> 1.1.16-2
- Update to 1.1.16

* Wed May 6 2009 Martin Stransky <stransky@redhat.com> 1.1.15-4
- build with -fno-strict-aliasing (#468415)

* Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 1.15.1-3
- Add patches for MFSA-2009-12, MFSA-2009-13

* Wed Mar 25 2009 Christopher Aillon <caillon@redhat.com> - 1.15.1-2
- Update default homepage

* Wed Mar  4 2009 Fedora Security Response Team <fedora-security-list@redhat.com> - 1.1.15-1
- Update to 1.1.15

* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.14-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Wed Feb 11 2009 Christopher Aillon <caillon@redhat.com> - 1.1.14-3
- Drop explicit requirement on desktop-file-utils

* Wed Jan 07 2009 Christopher Aillon <caillon@redhat.com> - 1.1.14-2
- Disable the crash dialog

* Wed Dec 17 2008 Kai Engert <kengert@redhat.com> - 1.1.14-1
- Update to 1.1.14
* Thu Dec 11 2008 Kai Engert <kengert@redhat.com> - 1.1.13-1
- Update to 1.1.13
- own additional directories, bug 474039
* Thu Sep 25 2008 Christopher Aillon <caillon@redhat.com> - 1.1.12-1
- Update to 1.1.12
* Sat Jul  6 2008 Christopher Aillon <caillon@redhat.com> - 1.1.10-1
- Update to 1.1.10
- Use bullet characters to match GTK+
* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> - 1.1.9-4
- Require mozilla-filesystem and drop its requires
* Thu Apr 17 2008 Kai Engert <kengert@redhat.com> - 1.1.9-3
- add several upstream patches, not yet released:
  425576 (crash), 323508, 378132, 390295, 421622
* Fri Mar 28 2008 Kai Engert <kengert@redhat.com> - 1.1.9-2
- SeaMonkey 1.1.9
* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> - 1.1.8-6
- Use the Fedora system bookmarks as default
* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> - 1.1.8-5
- Avoid conflicts between gecko debuginfo packages
* Thu Feb 14 2008 Kai Engert <kengert@redhat.com> - 1.1.8-4
- remove workaround for 432138, use upstream patch
* Sat Feb 09 2008 Kai Engert <kengert@redhat.com> - 1.1.8-3
- make it build with nss 3.12, mozilla bug 399589
- work around an issue with gcc 4.3.0, redhat bug 432138
* Fri Feb 08 2008 Kai Engert <kengert@redhat.com> - 1.1.8-2
- SeaMonkey 1.1.8
* Mon Jan 07 2008 Kai Engert <kengert@redhat.com> - 1.1.7-4
- Create and own /etc/skel/.mozilla
* Mon Dec 03 2007 Kai Engert <kengert@redhat.com> - 1.1.7-3
- fix dependencies, requires nspr 4.6.99 / nss 3.11.99
* Sun Dec 02 2007 Kai Engert <kengert@redhat.com> - 1.1.7-2
- SeaMonkey 1.1.7
* Mon Nov 05 2007 Kai Engert <kengert@redhat.com> - 1.1.6-2
- SeaMonkey 1.1.6
* Fri Oct 19 2007 Kai Engert <kengert@redhat.com> - 1.1.5-2
- SeaMonkey 1.1.5
* Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 1.1.3-8
- added fix for #246248 - firefox crashes when searching for word "do"
* Tue Aug 28 2007 Kai Engert <kengert@redhat.com> - 1.1.3-7
- Updated license tag
* Tue Aug  7 2007 Martin Stransky <stransky@redhat.com> 1.1.3-6
- removed plugin configuration utility
* Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 1.1.3-5
- unwrapped plugins moved to the old location
* Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 1.1.3-4
- added nspluginwrapper support
* Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> - 1.1.3-3
- added pango patches
* Fri Jul 20 2007 Kai Engert <kengert@redhat.com> - 1.1.3-2
- SeaMonkey 1.1.3
* Thu May 31 2007 Kai Engert <kengert@redhat.com> 1.1.2-2
- SeaMonkey 1.1.2
* Wed Feb 28 2007 Kai Engert <kengert@redhat.com> 1.1.1-2
- SeaMonkey 1.1.1
* Wed Feb 07 2007 Kai Engert <kengert@redhat.com> 1.1-2
- Update to SeaMonkey 1.1
- Pull in patches used by Firefox Fedora RPM package.
- Fix the DND implementation to not grab, so it works with new GTK+.
- Fix upgrade path from FC-5 by obsoleting the seamonkey subset
  packages which recently obsoleted mozilla in FC-5.
* Sat Dec 23 2006 Kai Engert <kengert@redhat.com> 1.0.7-1
- SeaMonkey 1.0.7
* Fri Nov 10 2006 Kai Engert <kengert@redhat.com> 1.0.6-2
- Do not run regchrome.
- Fix some .dat and .rdf ghost files.
* Thu Nov 09 2006 Kai Engert <kengert@redhat.com> 1.0.6-1
- SeaMonkey 1.0.6
* Thu Sep 14 2006 Kai Engert <kengert@redhat.com> 1.0.5-1
- SeaMonkey 1.0.5
* Wed Sep 06 2006 Kai Engert <kengert@redhat.com> 1.0.4-8
- patch5 -p0
* Wed Sep 06 2006 Kai Engert <kengert@redhat.com> 1.0.4-7
- Synch patches with those found in the Firefox package.
- Add missing, clean up BuildRequires
- Use --enable-system-cairo
- Use a dynamic approach to require at least the NSPR/NSS 
  library release used at build time.
* Tue Aug 15 2006 Kai Engert <kengert@redhat.com> 1.0.4-6
- Yet another forgotten patch file.
* Tue Aug 15 2006 Kai Engert <kengert@redhat.com> 1.0.4-5
- Commit forgotten visibility patch file.
* Fri Aug  4 2006 Kai Engert <kengert@redhat.com> 1.0.4-4
- Use a different patch to disable visibility.
* Fri Aug  4 2006 Kai Engert <kengert@redhat.com> 1.0.4-3
- Fix a build failure in mailnews mime code.
* Thu Aug 03 2006 Kai Engert <kengert@redhat.com> 1.0.4-2
- SeaMonkey 1.0.4
* Wed Jun 07 2006 Kai Engert <kengert@redhat.com> 1.0.2-1
- Update to SeaMonkey 1.0.2 release
* Fri Apr 14 2006 Kai Engert <kengert@redhat.com> 1.0.1-1
- Update to SeaMonkey 1.0.1 release
* Tue Apr 11 2006 Kai Engert <kengert@redhat.com> 1.0-11
- Fix PreReq statements
* Tue Apr 11 2006 Kai Engert <kengert@redhat.com> 1.0-10
- Added libXt-devel BuildRequires
* Mon Apr 10 2006 Kai Engert <kengert@redhat.com> 1.0-9
- Added dist suffix to release
* Fri Mar 17 2006 Kai Engert <kengert@redhat.com> 1.0-8
- Changed license to MPL
* Tue Mar 14 2006 Kai Engert <kengert@redhat.com> 1.0-7
- updated %%files section, removed %%preun,
- removed explicit nspr/nss requires
* Thu Mar 02 2006 Kai Engert <kengert@redhat.com> 1.0-6
- Use a single package for all included applications.
- Make sure installed JavaScript files are not executable.
- Disable AutoProv, use find-external-requires.
* Fri Feb 10 2006 Kai Engert <kengert@redhat.com> 1.0-4
- Addressed several review comments, see bugzilla.redhat.com #179802.
* Sat Jan 28 2006 Kai Engert <kengert@redhat.com> 1.0-1
- Initial version based on Seamonkey 1.0, using a combination of patches 
  from Mozilla 1.7.x, Firefox 1.5 and Thunderbird 1.5 RPM packages.