Blob Blame Raw
From 42e691b12c03aac388e39071f4b8d76cbc40e5c5 Mon Sep 17 00:00:00 2001
From: Vit Mojzis <vmojzis@redhat.com>
Date: Fri, 29 Jun 2018 10:34:14 +0200
Subject: [PATCH 1/2] Do not use -Werror during build

There are new warnings when setools are built with gcc 7 therefore we
want to suppress -Werror for now
---
 setup.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/setup.py b/setup.py
index aa4f14b..e4da575 100644
--- a/setup.py
+++ b/setup.py
@@ -62,7 +62,7 @@ ext_py_mods = [Extension('setools.policyrep.libpolicyrep', ['setools/policyrep/l
                          library_dirs=lib_dirs,
                          runtime_library_dirs=lib_dirs,
                          define_macros=macros,
-                         extra_compile_args=['-Werror', '-Wextra',
+                         extra_compile_args=['-Wextra',
                                              '-Waggregate-return',
                                              '-Wfloat-equal',
                                              '-Wformat', '-Wformat=2',
-- 
2.14.3