fdd5e4 Do not use -Werror during build

Authored and Committed by plautrba 2 years ago
    Do not use -Werror during build
    
    There are new warnings when setools are built with gcc 7 therefore we
    want to suppress -Werror for now
    
    Fixes:
    libqpol/policy_extend.c: In function ‘policy_extend’:
    libqpol/policy_extend.c:161:27: error: ‘%04zd’ directive output may be truncated writing between 4 and 10 bytes into a region of size 5 [-Werror=format-truncation=]
        snprintf(buff, 9, "@ttr%04zd", i + 1);
                               ^~~~~
    libqpol/policy_extend.c:161:22: note: directive argument in the range [1, 4294967295]
        snprintf(buff, 9, "@ttr%04zd", i + 1);
                          ^~~~~~~~~~~
    In file included from /usr/include/stdio.h:939:0,
                     from /usr/include/sepol/policydb/policydb.h:53,
                     from libqpol/policy_extend.c:29:
    /usr/include/bits/stdio2.h:64:10: note: ‘__builtin___snprintf_chk’ output between 9 and 15 bytes into a destination of size 9
       return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1,
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
            __bos (__s), __fmt, __va_arg_pack ());
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    cc1: all warnings being treated as errors
    error: command 'gcc' failed with exit status 1
    
        
file modified
+1 -1