#1 Fix Python 3 dependency from python2-transtats-cli (bz#1495860)
Merged 2 years ago by suanand. Opened 2 years ago by ishcherb.
rpms/ ishcherb/transtats-cli master  into  master

file modified
+8 -2

@@ -15,7 +15,7 @@ 

  

  Name:           %{name}

  Version:        0.1.0

- Release:        3%{?dist}

+ Release:        4%{?dist}

  Summary:        %{sum}

  License:        ASL 2.0

  URL:            https://github.com/%{project}/%{name}

@@ -64,6 +64,9 @@ 

  %install

  %if 0%{?with_python2}

  %py2_install

+ # Delete the Python 2 executable so that the Python 3

+ # version can take it's place.

+ rm %{buildroot}%{_bindir}/*

  %endif

  %py3_install

  

@@ -71,7 +74,6 @@ 

  %files -n python2-%{name}

  %doc README.md transtats.conf.example

  %license LICENSE

- %{_bindir}/%{project}

  %{python2_sitelib}/%{module}

  %{python2_sitelib}/%{name_with_underscore}-%{version}-py?.?.egg-info

  %{_mandir}/man1/transtats.1.gz

@@ -87,6 +89,10 @@ 

  

  

  %changelog

+ * Wed Oct 11 2017 Iryna Shcherbina <ishcherb@redhat.com> - 0.1.0-4

+ - Fix Python 3 dependency from python2-transtats-cli

+ Resolves: rhbz#1495860

+ 

  * Wed Sep 13 2017 Sundeep Anand <suanand AT redhat DOT com> - 0.1.0-3

  - Add man page to transtats-cli

  

According to the Fedora Packaging guidelines for Python, if the executables provide the same functionality independent of whether they are run on top of Python 2 or Python 3, then only the Python 3 version of the executable should be packaged.

This fixes: https://bugzilla.redhat.com/show_bug.cgi?id=1495860
Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=22383524

Pull-Request has been merged by suanand

2 years ago
Metadata