Blob Blame History Raw
From 7486aa2ce950f55a4be9049d514c412d7e45ddef Mon Sep 17 00:00:00 2001
From: Pavel Valena <pvalena@redhat.com>
Date: Thu, 20 Jul 2017 15:01:06 +0200
Subject: [PATCH] Fix dependencies for Vagrant 1.9.7.

---
 vagrant.gemspec | 21 ++++++++++++---------
 1 file changed, 12 insertions(+), 9 deletions(-)

diff --git a/vagrant.gemspec b/vagrant.gemspec
index c92ca17..aeee52f 100644
--- a/vagrant.gemspec
+++ b/vagrant.gemspec
@@ -12,7 +12,7 @@ Gem::Specification.new do |s|
   s.summary       = "Build and distribute virtualized development environments."
   s.description   = "Vagrant is a tool for building and distributing virtualized development environments."
 
-  s.required_ruby_version     = "~> 2.2", "< 2.4"
+  s.required_ruby_version     = "~> 2.2"
   s.required_rubygems_version = ">= 1.3.6"
   s.rubyforge_project         = "vagrant"
 
@@ -22,21 +22,24 @@ Gem::Specification.new do |s|
   s.add_dependency "listen", "~> 3.1.5"
   s.add_dependency "hashicorp-checkpoint", "~> 0.1.1"
   s.add_dependency "log4r", "~> 1.1.9", "< 1.1.11"
-  s.add_dependency "net-ssh", "~> 4.1.0"
+  s.add_dependency "net-ssh", ">= 4.1.0"
   s.add_dependency "net-sftp", "~> 2.1"
-  s.add_dependency "net-scp", "~> 1.2.0"
-  s.add_dependency "rb-kqueue", "~> 0.2.0"
+  s.add_dependency "net-scp", ">= 1.2.0"
+  # Remove Windows specific dependency.
+  # s.add_dependency "rb-kqueue", "~> 0.2.0"
   s.add_dependency "rest-client", ">= 1.6.0", "< 3.0"
-  s.add_dependency "wdm", "~> 0.1.0"
-  s.add_dependency "winrm", "~> 2.1"
-  s.add_dependency "winrm-fs", "~> 1.0"
-  s.add_dependency "winrm-elevated", "~> 1.1"
+  # s.add_dependency "wdm", "~> 0.1.0"
+  # s.add_dependency "winrm", "~> 2.1"
+  # s.add_dependency "winrm-fs", "~> 1.0"
+  # s.add_dependency "winrm-elevated", "~> 1.1"
 
   # NOTE: The ruby_dep gem is an implicit dependency from the listen gem. Later versions
   # of the ruby_dep gem impose an aggressive constraint on the required ruby version (>= 2.2.5).
   # Explicit constraint is defined to provide required dependency to listen without imposing
   # tighter restrictions on valid ruby versions
-  s.add_dependency "ruby_dep", "<= 1.3.1"
+  #
+  # Do not impose any Ruby version restrictions on Fedora.
+  # s.add_dependency "ruby_dep", "<= 1.3.1"
 
   # Constraint rake to properly handle deprecated method usage
   # from within rspec
-- 
2.7.5