Blob Blame Raw
Summary: X.Org X11 driver installation package
Name: xorg-x11-drivers
Version: 0.99.2
Release: 4.1
License: MIT/X11
Group: User Interface/X Hardware Support
URL: http://www.redhat.com
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
Obsoletes: xorg-x11

# *************************************************************************
# IMPORTANT: The ifarch sections below are MACHINE GENERATED.  DO NOT
#            hand edit, or the changes will be overwritten during the next
#            automatic update.
#
# I used the following to generate the list:
# for a in $(< xorg-all-drivers.txt ) ; do (echo -n "%ifarch " ;grep "^ExclusiveArch:" $a/devel/$a.spec | sed -e "s/^ExclusiveArch: //" ; echo -e "Requires: $a\n%endif\n") ; done
%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-acecad
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-aiptek
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-apm
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-ark
%endif

%ifarch %{ix86} x86_64 ia64 ppc alpha sparc sparc64
Requires: xorg-x11-drv-ati
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-calcomp
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-chips
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-cirrus
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-citron
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-cyrix
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-digitaledge
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-dmc
%endif

%ifarch %{ix86} x86_64 ia64 ppc alpha sparc sparc64
Requires: xorg-x11-drv-dummy
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-dynapro
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-elo2300
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-elographics
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-evdev
%endif

%ifarch %{ix86} x86_64 ia64 ppc alpha sparc sparc64
Requires: xorg-x11-drv-fbdev
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-fpit
%endif

%ifarch %{ix86} alpha
Requires: xorg-x11-drv-glint
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-hyperpen
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-i128
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-i740
%endif

%ifarch %{ix86} x86_64 ia64
Requires: xorg-x11-drv-i810
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-jamstudio
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-joystick
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-keyboard
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-magellan
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-magictouch
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-mga
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-microtouch
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-mouse
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-mutouch
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-neomagic
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-nsc
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-nv
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-palmax
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-penmount
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-rendition
%endif

%ifarch %{ix86} x86_64 ppc
Requires: xorg-x11-drv-s3
%endif

%ifarch %{ix86} x86_64 ppc
Requires: xorg-x11-drv-s3virge
%endif

%ifarch %{ix86} x86_64 ppc
Requires: xorg-x11-drv-savage
%endif

%ifarch %{ix86} x86_64
Requires: xorg-x11-drv-siliconmotion
%endif

%ifarch %{ix86} x86_64 ppc
Requires: xorg-x11-drv-sis
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-sisusb
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-spaceorb
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-summa
%endif

%ifarch %{ix86} x86_64
Requires: xorg-x11-drv-tdfx
%endif

%ifarch %{ix86} x86_64 ppc
Requires: xorg-x11-drv-trident
%endif

%ifarch %{ix86}
Requires: xorg-x11-drv-tseng
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-ur98
%endif

%ifarch %{ix86} x86_64 ia64 ppc alpha sparc sparc64
Requires: xorg-x11-drv-vesa
%endif

%ifarch %{ix86} x86_64 ia64 ppc alpha sparc sparc64
Requires: xorg-x11-drv-vga
%endif

%ifarch %{ix86} x86_64
Requires: xorg-x11-drv-via
%endif

%ifarch %{ix86} x86_64 ia64
Requires: xorg-x11-drv-vmware
%endif

%ifarch %{ix86} x86_64 ia64 ppc
Requires: xorg-x11-drv-void
%endif

%ifarch %{ix86} x86_64 ia64 ppc alpha sparc sparc64
Requires: xorg-x11-drv-voodoo
%endif

%description
The purpose of this package is to require all of the individual X.Org
driver rpms, to allow the OS installation software to install all drivers
all at once, without having to track which individual drivers are present
on each architecture.  By installing this package, it forces all of the
individual driver packages to be installed.

%prep
%build
%install
rm -rf $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc


%changelog
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-4.1
- rebuilt for new gcc4.1 snapshot and glibc changes

* Wed Nov 23 2005 Mike Harris <mharris@redhat.com> 0.99.2-4
- Add ur98 driver back, as it is part of X11R7 RC2

* Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> - 0.99.2-3
- ur98 driver doesn't exist

* Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> - 0.99.2-2
- add an obsoletes on xorg-x11 to get pulled in on upgrades

* Tue Nov 15 2005 Mike Harris <mharris@redhat.com> 0.99.2-1
- Initial build.