Blame use-dwarf4-by-default/main.fmf

675b60e
summary: Test that clang uses DWARFv4 by default
675b60e
test: "$WITH_SCL ./test.sh"
675b60e
require:
675b60e
  - libgcc
ab3d3a4
framework: shell
ab3d3a4
tier: 1
ab3d3a4
component:
ab3d3a4
  - llvm-toolset
ab3d3a4
  - clang
ab3d3a4
extra-summary: /tools/clang/use-dwarf4-by-default
ab3d3a4
extra-task: /tools/clang/use-dwarf4-by-default
ab3d3a4
extra-nitrate: TC#0614134
ab3d3a4
675b60e
adjust:
675b60e
  # Common requirements when LLVM is not SCL-ized
675b60e
  - require+:
675b60e
      - clang
675b60e
      - llvm
675b60e
    when: "collection is not defined"
675b60e
675b60e
  # Requirements for SCL-ized LLVM
675b60e
  - require+:
675b60e
      - llvm-toolset-13.0-clang
675b60e
      - llvm-toolset-13.0-llvm
675b60e
    when: "collection == llvm-toolset-13.0"
675b60e
  - require+:
675b60e
      - llvm-toolset-14.0-clang
675b60e
      - llvm-toolset-14.0-llvm
675b60e
    when: "collection == llvm-toolset-14.0"
Edjunior Machado af1b185
  - require+:
Edjunior Machado af1b185
      - llvm-toolset-15.0-clang
Edjunior Machado af1b185
      - llvm-toolset-15.0-llvm
Edjunior Machado af1b185
    when: "collection == llvm-toolset-15.0"