Blob Blame History Raw
summary: Test that clang uses DWARFv4 by default
test: "$WITH_SCL ./test.sh"
require:
  - libgcc
framework: shell
tier: 1
component:
  - llvm-toolset
  - clang
extra-summary: /tools/clang/use-dwarf4-by-default
extra-task: /tools/clang/use-dwarf4-by-default
extra-nitrate: TC#0614134

adjust:
  # Common requirements when LLVM is not SCL-ized
  - require+:
      - clang
      - llvm
    when: "collection is not defined"

  # Requirements for SCL-ized LLVM
  - require+:
      - llvm-toolset-13.0-clang
      - llvm-toolset-13.0-llvm
    when: "collection == llvm-toolset-13.0"
  - require+:
      - llvm-toolset-14.0-clang
      - llvm-toolset-14.0-llvm
    when: "collection == llvm-toolset-14.0"
  - require+:
      - llvm-toolset-15.0-clang
      - llvm-toolset-15.0-llvm
    when: "collection == llvm-toolset-15.0"