mcrha / rpms / rest

Forked from rpms/rest 12 months ago
Clone
Blob Blame History Raw
Name:           rest
Version:        0.5
Release:        1%{?dist}
Summary:        A library for access to RESTful web services

Group:          System Environment/Libraries
License:        LGPLv2
URL:            http://moblin.org/projects/librest
Source0:        http://git.moblin.org/cgit.cgi/lib%{name}/snapshot/lib%{name}-%{version}.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildRequires: glib2-devel
BuildRequires: libsoup-devel
BuildRequires: libxml2-devel
BuildRequires: gtk-doc
BuildRequires: pkgconfig

# Require these because the git tarball doesn't have the configure built
BuildRequires: libtool
BuildRequires: automake
BuildRequires: autoconf

%description
This library was designed to make it easier to access web services that
claim to be "RESTful". A RESTful service should have urls that represent 
remote objects, which methods can then be called on. The majority of services 
don't actually adhere to this strict definition. Instead, their RESTful end 
point usually has an API that is just simpler to use compared to other types 
of APIs they may support (XML-RPC, for instance). It is this kind of API that 
this library is attempting to support.

%package devel
Summary: Development package for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: pkgconfig
Requires: gtk-doc

%description devel
Files for development with %{name}.

%prep
%setup -q -n librest-%{version}

%build
./autogen.sh
%configure --disable-static --enable-gtk-doc
make %{?_smp_mflags}

%install
rm -rf %{buildroot}
make install DESTDIR=%{buildroot}

#Remove libtool archives
rm -rf %{buildroot}/%{_libdir}/*.la

%clean
rm -rf %{buildroot}

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING README
%{_libdir}/librest.so.0
%{_libdir}/librest.so.0.0.0

%files devel
%defattr(-,root,root,-)
%{_includedir}/rest
%{_libdir}/pkgconfig/rest.pc
%{_libdir}/librest.so
%{_datadir}/gtk-doc/html/rest

%changelog
* Tue Jul 14 2009 Peter Robinson <pbrobinson@gmail.com> 0.5-1
- Update to 0.5

* Mon Jun 22 2009 Peter Robinson <pbrobinson@gmail.com> 0.4-1
- Update to 0.4

* Wed Jun 17 2009 Peter Robinson <pbrobinson@gmail.com> 0.3-1
- Initial packaging