Blob Blame History Raw
%define pkgname font-utils
# FIXME: Upstream tarball is 0.99.0, which would require
# us to add an "Epoch: 1" to this package in order for rpm to upgrade from
# the FC4 (and earlier) monolithic xorg-x11-xfs-6.8.x rpm package.  Since
# it is currently unknown what the final upstream tarball version is likely
# to be called, I am avoiding adding Epoch, and instead using a 6.99.99.x
# version number for the time being.  This allows us to make sure xfs will
# upgrade from older releases to the new release, allows us to avoid adding
# an Epoch tag possibly unnecessarily - as Epoch is permanent and very evil.
# If upstream later names it "xfs-7.0", then we bump the version to that,
# and everything just works.
%define upstreamversion 0.99.1

Summary: X.Org X11 font utilities
Name: xorg-x11-%{pkgname}
Version: 6.99.99.901
Release: 2
License: MIT/X11
Group: User Interface/X
URL: http://www.x.org
Source0: http://xorg.freedesktop.org/releases/X11R7.0-RC1/everything/bdftopcf-%{upstreamversion}.tar.bz2
Source1: http://xorg.freedesktop.org/releases/X11R7.0-RC1/everything/fonttosfnt-%{upstreamversion}.tar.bz2
Source2: http://xorg.freedesktop.org/releases/X11R7.0-RC1/everything/mkfontdir-%{upstreamversion}.tar.bz2
Source3: http://xorg.freedesktop.org/releases/X11R7.0-RC1/everything/mkfontscale-%{upstreamversion}.tar.bz2
Source4: http://xorg.freedesktop.org/releases/X11R7.0-RC1/everything/font-util-%{upstreamversion}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildRequires: pkgconfig
# xorg-x11-libXfont-devel needed for bdftopcf
BuildRequires: libXfont-devel
# xorg-x11-libX11-devel needed for fonttosfnt
BuildRequires: libX11-devel
# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
BuildRequires: libfontenc-devel
# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
BuildRequires: freetype-devel
# zlib-devel needed for bdftopcf
BuildRequires: zlib-devel
# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
# from it directly.
BuildRequires: xorg-x11-proto-devel

Provides: %{pkgname}
Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, bdftruncate, ucs2any
# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
# is needed for upgrades to work properly from OS releases that had XFree86
Obsoletes: XFree86-font-utils, xorg-x11-font-utils
# NOTE: XFree86 package used to contain bdftopcf, so this is needed for
# upgrades to work.  It also contained mkfontdir/mkfontscale at one point,
# so we just Conflict without a version specification.
Conflicts: XFree86
# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
# xorg-x11-font-utils in 6.7.99.903-3
Conflicts: xorg-x11-base-fonts <= 6.7.99.903-3
# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
Conflicts: xorg-x11-tools <= 6.7.99.903-3

%description
X.Org X11 font utilities required for font installation, conversion,
and generation.

%prep
%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4

%build
# Build bdftopcf
{
   pushd bdftopcf-%{upstreamversion}
   %configure
   make
   popd
}
# Build fonttosfnt
{
   pushd fonttosfnt-%{upstreamversion}
   %configure
   make
   popd
}
# Build mkfontdir
{
   pushd mkfontdir-%{upstreamversion}
   %configure
   make
   popd
}
# Build mkfontscale
{
   pushd mkfontscale-%{upstreamversion}
   %configure
   make
   popd
}

# Build font-util
{
   pushd font-util-%{upstreamversion}
   %configure
   make
   popd
}

%install
rm -rf $RPM_BUILD_ROOT
# Install bdftopcf
{
   pushd bdftopcf-%{upstreamversion}
   %makeinstall
   popd
}
# Install fonttosfnt
{
   pushd fonttosfnt-%{upstreamversion}
   %makeinstall
   popd
}
# Install mkfontdir
{
   pushd mkfontdir-%{upstreamversion}
   %makeinstall
   popd
}
# Install mkfontscale
{
   pushd mkfontscale-%{upstreamversion}
   %makeinstall
   popd
}
# Install font-util
{
   pushd font-util-%{upstreamversion}
#   %%makeinstall
   make install DESTDIR=$RPM_BUILD_ROOT
   popd
}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc
%dir %{_bindir}
%{_bindir}/bdftopcf
%{_bindir}/bdftruncate
%{_bindir}/fonttosfnt
%{_bindir}/mkfontdir
%{_bindir}/mkfontscale
%{_bindir}/ucs2any
%dir %{_libdir}
%dir %{_libdir}/X11
%dir %{_libdir}/X11/fonts
%dir %{_libdir}/X11/fonts/util
%{_libdir}/X11/fonts/util/map-*
%dir %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/fontutil.pc
%dir %{_mandir}
%dir %{_mandir}/man1x
%{_mandir}/man1x/bdftopcf.1x*
%{_mandir}/man1x/bdftruncate.1x*
%{_mandir}/man1x/fonttosfnt.1x*
%{_mandir}/man1x/mkfontdir.1x*
%{_mandir}/man1x/mkfontscale.1x*
%{_mandir}/man1x/ucs2any.1x*

%changelog
* Wed Nov 9 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
- Glob util/map-* files in file manifest.
- Added missing "Obsoletes: xorg-x11-font-utils".
- Added "BuildRequires: pkgconfig".

* Sun Nov 6 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
- Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
  ucs2any, bdftruncate.

* Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  X11R7 RC1.
- Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
- Updated file manifest to to find the manpages in "man1x".

* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
- Initial build.