Blob Blame History Raw
%define archivename     dejavu-sfd
# This macro has the same value as %{version}, except when testing pre-release snapshots
%define archiveversion  %{version}-1
%define fontdir         %{_datadir}/fonts/dejavu

# Let the perl Maintainer worry about Unicode.org data files (updates, licensing)
%define Blocks		%(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/Blocks.txt
%define UnicodeData	%(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/UnicodeData.txt

Name:      dejavu-fonts
Version:   2.3
Release:   1%{?dist}
Summary:   DejaVu Fonts
Group:     User Interface/X
License:   Redistributable, with restrictions
URL:       http://dejavu.sf.net/
Source:    http://prdownloads.sourceforge.net/dejavu/%{archivename}-%{archiveversion}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: fontforge
# The CPAN sources do not declare perl(Font::TTF)
BuildRequires: perl-Font-TTF
# Needed to compute unicode coverage
BuildRequires: %{Blocks} %{UnicodeData}
BuildArch: noarch
Conflicts: fontconfig < 2.3.93

%description
The DejaVu fonts are a font family based on the Bitstream Vera Fonts release
1.10. Its purpose is to provide a wider range of characters (see Current status
page for more information) while maintaining the original look and feel through
the process of collaborative develop

%prep
%setup -q -n %{archivename}-%{version}

%build
./generate.sh
./status.pl %{version} status.txt *.sfd > status.txt.new
mv status.txt.new status.txt
./unicover.pl %{UnicodeData} %{Blocks} \
              DejaVuSans.sfd Sans \
              DejaVuSerif.sfd Serif \
              DejaVuMonoSans.sfd "Sans Mono" > unicover.txt

%check
# Current upstream files are full of "problems"
# Do not panic if the output is long
./problems.pl -l 3 *.sfd

%install
/bin/rm -rf %{buildroot}

#fonts
install -d -m 0755 %{buildroot}%{fontdir}
install -m 0644 generated/*.ttf  %{buildroot}%{fontdir}

%clean
/bin/rm -rf %{buildroot}


%post
if [ -x %{_bindir}/fc-cache ]; then 
  %{_bindir}/fc-cache %{_datadir}/fonts
fi

%postun
if [ "$1" = "0" ]; then
  if [ -x %{_bindir}/fc-cache ]; then 
    %{_bindir}/fc-cache %{_datadir}/fonts
  fi
fi


%files
%defattr(0644,root,root,0755)
%doc *.txt AUTHORS BUGS LICENSE NEWS README

%dir %{fontdir}
%{fontdir}/*.ttf

%changelog
* Mon Feb 20 2006 Nicolas Mailhot <nicolas.mailhot at laposte.net> - 2.3-1
- 2.3

* Mon Feb 13 2006 Nicolas Mailhot <nicolas.mailhot at laposte.net> - 2.2-6
- rebuilt for new gcc4.1 snapshot and glibc changes

* Sun Feb 12 2006 Nicolas Mailhot <nicolas.mailhot at laposte.net> 2.2-5
- downgrade fontforge requirement following bug #181052 resolution

* Sun Feb 12 2006 Nicolas Mailhot <nicolas.mailhot at laposte.net> 2.2-4
- WARNING: in an effort to get Fedora Extras as self-hosting as possible
  starting from this release ttf files are regenerated from sfd sources

* Mon Jan 16 2006 Nicolas Mailhot <nicolas.mailhot at laposte.net> 2.2-2
- bump release to ensure graceful FC4 -> FC5 update
- bump again because of bas CVS tag

* Mon Jan 16 2006 Nicolas Mailhot <nicolas.mailhot at laposte.net> 2.2-1
- 2.2

* Wed Dec 28 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 2.1-1
- 2.1

* Sun Nov 13 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 2.0-1
- 2.0!

* Fri Oct 28 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.15-2
- add ghosting of %{fontdir}/fonts.cache-2 since it seems
  needed nowadays

* Sun Oct 16 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.15-1
- 1.15

* Sat Oct 8 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.14-1
- 1.14
- still using prepackaged TTFs as the FE fontforge package is too old

* Sun Jul 31 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.12-1
- 1.12

* Thu Jun 23 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.11-1
- 1.11

* Mon May 22 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.10-1
- 1.10

* Sat May 21 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.9-2
- 1.9
- submission to FCE

* Sat Feb 19 2005 Nicolas Mailhot <nicolas.mailhot at laposte.net> 1.7-1
- initial build - using vera as template

* Sat Jan 08 2005 Florian La Roche <laroche@redhat.com>
- rebuilt to get rid of legacy selinux filecontexts