Blob Blame History Raw
%global srcname     astroid
%global commit      8d57ce2f3e226c2ac3cdd7f6a57dac2dd5ec5a4b
%global shortcommit %(c=%{commit}; echo ${c:0:7})

Version:        3.0.0~a6~20230628%{shortcommit}

Name:           python-astroid
# Note: please check that this doesn't break pylint before committing and building! -GC
Release:        %autorelease
Summary:        Common base representation of python source code for pylint and other projects
License:        LGPL-2.1-or-later
URL:            https://pypi.org/project/astroid/
Source0:        https://github.com/pylint-dev/%{srcname}/archive/%{commit}/%{srcname}-%{commit}.tar.gz

BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3-pytest

%global _description %{expand:
The aim of this module is to provide a common base representation of python
source code for projects such as pychecker, pyreverse, pylint...
It provides a compatible representation which comes from the _ast module. It
rebuilds the tree generated by the builtin _ast module by recursively walking
down the AST and building an extended ast. The new node classes have additional
methods and attributes for different usages. They include some support for
static inference and local name scopes. Furthermore, astroid builds partial
trees by inspecting living objects.}

%description %_description

%package -n python3-%{srcname}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{srcname}}

%description -n python3-%{srcname} %_description

%prep
%autosetup -n %{srcname}-%{commit} -p1

%generate_buildrequires
%pyproject_buildrequires

%build
%pyproject_wheel

%install
%pyproject_install
# https://github.com/pylint-dev/astroid/pull/2156#issuecomment-1612640531
rm -rf %{buildroot}%{python3_sitelib}/tests
rm %{buildroot}%{python3_sitelib}/requirements*
rm %{buildroot}%{python3_sitelib}/tox.ini


%check
%{python3} -m pytest -v


%files -n python3-%{srcname}
%license LICENSE
%{python3_sitelib}/astroid
%{python3_sitelib}/astroid*.dist-info/

%changelog
%autochangelog